Standalone Controller Series - Commander Ecosystem

The Standalone Controller Series within the Commander Ecosystem provides a family of fully integrated motion controllers designed for precise, multi-axis control with minimal system integration effort. Built on the proven Commander motion control core, these controllers combine high-performance motion capability with flexible communication options and standalone program execution.

All standalone controllers support USB and RS-485 communication and can execute downloaded programs independently of a host system, making them ideal for embedded and distributed motion applications. Mechanical and electrical specifications are provided in each product manual, while command structure and operational behavior are common across the Commander platform and documented in the main Commander reference materials.

CMD-4EX-SA — 4-Axis Standalone Motion Controller

The CMD-4EX-SA is a next-generation 4-axis stepper/servo standalone programmable motion controller based on the Commander core (CMD-4CR). It is designed for applications requiring coordinated multi-axis control with reduced integration complexity.

The CMD-4EX-SA is available with multiple top board configurations:

• TBB / TBS: Controller-only configurations (no integrated motor drivers)
• TBD: Controller with integrated stepper motor drivers

These options allow users to select the appropriate level of system integration based on application requirements.

Jump to the CMD-4EX-SA manual

Migrating from the PMX-4EX-SA controller, see the Migration Quick Guide.

CMD-2EX-SA — 2-Axis Standalone Motion Controller

The CMD-2EX-SA is a 2-axis standalone motion controller designed for applications that require compact, high-performance motion control without integrated motor drivers. It delivers full Commander functionality in a simplified, easy-to-integrate form factor.

This controller is best suited for systems utilizing external drives while maintaining access to the Commander command set and standalone execution capability.

Jump to the CMD-2EX-SA manual

Migrating from the PMX-2EX-SA controller, see the Migration Quick Guide.

CMD-2ED-SA — 2-Axis Standalone Controller with Integrated Drivers

The CMD-2ED-SA is a 2-axis standalone motion controller with integrated stepper motor drivers, providing a compact, all-in-one solution for motion systems.

By combining controller and driver functionality in a single unit, the CMD-2ED-SA reduces component count, simplifies system design, and accelerates deployment for stepper-based applications.

Jump to the CMD-2ED-SA manual

Migrating from the PMX-2ED-SA controller, see the Migration Quick Guide

Copyright © 2021-2026 by NIPPON PULSE AMERICA, INC. All Rights Reserved.


Copyright

Copyright

Copyright © 2021-2026 by NIPPON PULSE AMERICA, INC. All Rights Reserved.

First edition, October 2019

Current edition, July 2026

You may not reproduce or translate into any language in any form any part of this publication without written permission from NIPPON PULSE AMERICA, INC.

NIPPON PULSE AMERICA, INC. makes no representations or warranties regarding the content of this document. We reserve the right to revise this document any time without notice and obligation.


Cautions

Copyright ››

Cautions

  • Copying any part of this manual without written approval is prohibited.
  • The specifications of this controller may be changed without prior notice.
  • If you find unclear, incomplete, or incorrect content, contact us using the [image] link at the bottom of the page to provide feedback.
  • NIPPON PULSE AMERICA, INC. is not responsible for any results that occur from using this controller.
  • The Commander core is designed for use in commercial apparatus (office machines, communication equipment, measuring equipment, and household appliances). If you use it in any device that requires high quality and reliability, or where faults or malfunctions may directly injure humans or endanger human survival (such as in nuclear power control devices, aviation devices or spacecraft, traffic signals, fire control, or various types of safety devices), NIPPON PULSE AMERICA, INC. is not liable for any problem that occurs, even if it was directly caused by the Commander core. Customers must provide their own safety measures to ensure appropriate performance in all circumstances.

Explanation of the descriptions in this manual

  • The X, Y, Z and U in terminal names and bit names refer to the X-axis, Y-axis, Z-axis, and U-axis, respectively.
  • Terminals with a / (ex. /RST) are negative logic. Their logic cannot be changed. Terminals without a / are positive logic. Their output logic can be changed.
  • When describing the bits in registers, n refers to the bit position. A 0 means that the bit is in position 0 and that it is prohibited to write to any bit other than 0. This bit always return a 0 when read out.

Copyright © 2019-2026 by NIPPON PULSE AMERICA, INC. All Rights Reserved.


CMD-2ED-SA Contoller

CMD-2ED-SA

Advanced 2-Axis

Stepper Motor Controller + Driver

CMD-2ED-SA

CMD-2ED-SA — 2-Axis Standalone Controller with Integrated Drivers

The CMD-2ED-SA is a 2-axis standalone motion controller with integrated stepper motor drivers, providing a compact, all-in-one solution for motion systems.

Communication to the CMD-2ED-SA can be established over USB or RS485. It is also possible to download a standalone program to the device and have it run independent of a host.

This manual provides detailed information on the mechanical and electrical specifications of the CMD-2ED-SA. See the Commander Manual and the NPA Command Reference for command structure, operational details, firmware updates, software tools, and additional support resources.

Note: If you are migrating from the PMX-2ED-SA controller, see the Migration Quick Guide


1.0 Features

CMD-2ED-SA Contoller ››
  • Power
    • +12VDC to +24VDC power input / Logic
    • +12VDC to +24VDC motor power
    • 3.3V logic level, 5V tolerant
  • Communication
    • USB 2.0, HID compatible. No driver signature required
    • RS-485 ASCII, 9600, 19200, 38400, 57600, 115200 baud rates available
  • Control
    • Command control from PC through USB or serial communication
    • Standalone control allows operation separate from PC, using a BASIC-like programming language known as A-SCRIPT
  • Utility software
    • Allows for operation check by utility software
    • Compile, write and read standalone programs
  • Motor interface
    • Maximum pulse output rate of 1.25M PPS
    • Integrated bipolar stepper motor driver with up to 128 micro-stepping
  • Homing Routines
    • 13 different built-in homing routines available, high speed and low speed.
  • Positioning operations
    • Selectable trapezoidal or s-curve acceleration
    • High-speed correction function for short movements
    • Absolute positioning or incremental positioning can be selected
    • On-the-fly speed change (speed overridden during movement).
    • On-the-fly target position change (target position overridden during movement).
    • Coordinated motion
      • Linear (XY) (2 axis)
  • Inputs/Outputs
    • With integrated noise filter, to reduce switch bounce
    • A/B/Z encoder inputs for XY (TTL Compatible)
      • Maximum frequency of 6.5 MHz (26M counts with 4x Multiplication)
      • StepNLoop closed-loop position verification algorithm (XY)
    • Digital I/O
      • 4 Opto-isolated inputs
      • 4 Opto-isolated outputs
      • 26 general purpose 3V3 logic (Opto-isolated with optional JBD-4EX-I26)
      • +Limit/-Limit/Home inputs for XY
      • 2 Latching inputs
    • Analog I/O
      • Two 12-bit analog inputs (0-5V)
      • Joystick operation with analog input (X-axis, Y-axis)
  • Stepper Motor Driver (TBD)
    • Directly drive 2 bipolar stepper motors
    • PWM-controlled constant-current drive
    • Low on-resistance MOSFET output stage
    • Stepping resolutions of full, half, quarter, 1/8, 1/16, 1/32, 1/64, and 1/128 step
      • Stepping resolution can be changed on-the-fly.
    • High-efficiency motor current control mechanism (ADMD: Advanced Dynamic Mixed Decay)
    • Built-in anti-stall architecture (AGC: Active Gain Control)
    • Motor drive voltage 12 to 24Vdc
    • Motor current 0.19A to 2.3A
    • Multi error detection functions:
      • Thermal shutdown (TSD)
      • Over-current (ISD)
      • Motor load open (OPD)


2.0 Electrical Specifications

CMD-2ED-SA Contoller ››

CMD-2ED-SA Controller Electrical Specifications

Parameter | Min | Max | Units
Main Power Input | +12 | +24 | V
 | - | 300 | mA
Driver Power Input | +12 | +24 | V
 | - | 2.5 | A
Opto-supply Power Input | +12 | +24 | V
 | - | 250 | mA
Digital Input Forward Diode Current * | 4 | 8 | mA
Digital Output Collector Voltage + | +12 | +24 |
Digital Output Sink Current ± | - | 25 | mA
Operating Temperature ≥ | -20 | +80 | °C
Storage Temperature ≥ | -55 | +150 | °C

* Internally current limited

+ From Opto-supply Power Input

± Each output, no internally current limit

≥ Based on component rating


3.0 Dimensions

CMD-2ED-SA Contoller ››

CMD-2ED-SA Controller Dimensions

(Need new image)


4.0 Stepper Motor Driver Overview

CMD-2ED-SA Contoller ››

Stepper Motor Driver Overview

The CMD-2ED-SA has two built-in microstep drivers, allowing the controller to directly drive 2 stepper motors.

On this page:

  • Microstep
  • Driver Current
  • Configuring the Driver Current and Microstep

Microstep

The CMD-2ED-SA has 4 microstepping options including full step, 1/2 step, 1/4 step, and 1/8 step. In general, the number of microsteps per revolution can be determined by the follow equation, where "DEGREE" is the full step angle of motor and "USTEP" is the microstep setting.

Micosteps/Revolution = 360° / (DEGREE * USTEP)

For example, using a 1.8° motor and a microstep setting of 1/8, the number of microsteps/revolution would be [360° / (1.8° * 1/8)] = 1600.

Driver Current

The CMD-2ED-SA will have a maximum rated current output of 1.5A. The current settings should not exceed the rated current of the motor being used. Setting the driver current higher than the maximum rated current will overheat and potentially damage the motor. It is recommended to use a current setting that is in the range of 60-80% of the maximum rated current for the motor.

Configuring the Driver Current and Microstep

The CMD-2ED-SA contains a series of jumpers that are used to configure the microstep and driver current settings.

Figure 5.0

To set the current, open up the top cover. There are two dual row jumper headers JP1 (for X axis) and JP2 (for Y axis).

There are four preset current settings: 0.8A, 0.7A, 0.5A, and 0.4A. Any of these current setting can be selected using a jumper.

For custom current setting, use the following formula to get the resistor value and solder across the custom current setting pins.

Resistor Value = [4167 / Current (A)] - 1000

For example, to set the current to 0.3A, resistor value will be 12.9K Ohm.

To set the microstep, use the SW1 (for X axis) and SW2 (for Y axis) headers.

 | MS1 | MS2
1/8th microstep | Open | Open
¼ microstep | Open | Close
½ microstep | Close | Open
Full step | Close | Close


5.0 Pin Descriptions

CMD-2ED-SA Contoller ››

CMD-2ED-SA Controller Pin Descriptions

The CMD-2ED-SA must be supplied with +12VDC to +24VDC.

In this section

  • 2-Pin Connector (5.08mm) – Controller Power
  • 3-Pin Connector (3.81mm) - RS485
  • 2-Pin Connector (5.08mm) – Driver Power
  • 4-Pin Connectors (2.54mm) - Motor
  • 50-Pin Connector Control/Encoder IO

See also:

  • Interface Circuit
  • Limit, Home, and Digital Inputs
  • Digital Outputs
  • Encoder Input Connection
  • Analog Inputs


5.1 2-Pin Connector (5.08mm) – Controller Power

CMD-2ED-SA Contoller ›› 5.0 Pin Descriptions ››

2-Pin Connector (5.08mm) – Controller Power

(Need new image)

Pin # | In/Out | Name | Description | I/F circuit
1 | I | G | Ground |
2 | I | V+ | Power Input +12 to +24 VDC

Mating Connector Description: 2 pin 0.2” (5.08mm) connector

Mating Connector Manufacturer: On-Shore

Mating Connector Manufacturer Part: 1EDZ950/2

1 Other 5.08mm compatible connectors can be used.


5.2 3-Pin Connector (3.81mm) - RS485

CMD-2ED-SA Contoller ›› 5.0 Pin Descriptions ››

3-Pin Connector (3.81mm) - RS485

(Need new image)

Pin # | In/Out | Name | Description
1 | I/O | 485+ | RS-485 plus signal
2 | I/O | 485- | RS-485 minus signal
3 | I | G | Ground

Mating Connector Description: 3 pin 0.15” (3.81mm) connector

Mating Connector Manufacturer: On-Shore

Mating Connector Manufacturer Part: 1EDZ1550/3

1Other 3.81mm compatible connectors can be used.


5.3 2-Pin Connector (5.08mm) – Driver Power

CMD-2ED-SA Contoller ›› 5.0 Pin Descriptions ››

2-Pin Connector (5.08mm) – Driver Power

Pin # | In/Out | Name | Description
1 | I | G | Ground
2 | I | V+ | Power Input +12 to +24 VDC

Mating Connector Description: 2 pin 0.2” (5.08mm) connector

Mating Connector Manufacturer: On-Shore

Mating Connector Manufacturer Part: 1EDZ950/2

1Other 5.08mm compatible connectors can be used.


5.4 4-Pin Connectors (2.54mm) - Motor

CMD-2ED-SA Contoller ›› 5.0 Pin Descriptions ››

4-Pin Connectors (2.54mm) - Motor

Pin # | In/Out | Name | Description
1 | O | AX | Bi-polar Step Motor – X-axis Phase A
2 | O | /AX | Bi-polar Step Motor – X-axis Phase /A
3 | O | BX | Bi-polar Step Motor – X-axis Phase B
4 | O | /BX | Bi-polar Step Motor – X-axis Phase /B

Pin # | In/Out | Name | Description
1 | O | AY | Bi-polar Step Motor – Y-axis Phase A
2 | O | /AY | Bi-polar Step Motor – Y-axis Phase /A
3 | O | BY | Bi-polar Step Motor – Y-axis Phase B
4 | O | /BY | Bi-polar Step Motor – Y-axis Phase /B

Mating Connector Description: 4 pin 0.1" (2.54mm) connector

Mating Connector Manufacturer: AMP/Tyco

Mating Connector Manufacturer Part: 1770602-4

1Other 5.08mm compatible connectors can be used.


5.6 50-Pin Connector Control/Encoder IO

CMD-2ED-SA Contoller ›› 5.0 Pin Descriptions ››

50-Pin Connector Control/Encoder IO

Pin # | In/Out | Name | Description
1 | O | +5V | +5V
2 | O | G | Ground
3 | I | AX | A Channel Encoder Input [X-Axis]
4 | I | /AX | /A Channel Encoder Input [X-Axis]
5 | I | BX | B Channel Encoder Input [X-Axis]
6 | I | /BX | /B Channel Encoder Input [X-Axis]
7 | I | ZX | Z Index Encoder Input [X-Axis]
8 | I | /ZX | /Z Index Encoder Input [X-Axis]
9 | I | AY | A Channel Encoder Input [Y-Axis]
10 | I | /AY | /A Channel Encoder Input [Y-Axis]
11 | I | BY | B Channel Encoder Input [Y-Axis]
12 | I | /BY | /B Channel Encoder Input [Y-Axis]
13 | I | ZY | Z Index Encoder Input [Y-Axis]
14 | I | /ZY | /Z Index Encoder Input [Y-Axis]
15 | I | AI1 | Analog Input 1
16 | I | AI2 | Analog Input 2
17 | I | +LX | +Limit [X-Axis]
18 | I | -LX | -Limit [X-Axis]
19 | I | HX | Home [X-Axis]
20 | NC | NC | No Connection
21 | I | +LY | +Limit [Y-Axis]
22 | I | -LY | -Limit [Y-Axis]
23 | I | HY | Home [Y-Axis]
24 | NC | NC | No Connection
25 | NC | NC | No Connection
26 | NC | NC | No Connection
27 | NC | NC | No Connection
28 | NC | NC | No Connection
29 | NC | NC | No Connection
30 | NC | NC | No Connection
31 | I | Opto- Supply | Opto-Supply Input +12 to +24VDC
32 | I | Opto- Ground | Opto-Ground
33 | I | DI1 | Digital Input 1
34 | I | DI2 | Digital Input 2
35 | I | DI3 | Digital Input 3
36 | I | DI4 | Digital Input 4
37 | I | DI5 | Digital Input 5
38 | I | DI6 | Digital Input 6
39 | I | DI7 | Digital Input 7
40 | I | DI8 | Digital Input 8
41 | O | DO1 | Digital Output 1
42 | O | DO2 | Digital Output 2
43 | O | DO3 | Digital Output 3
44 | O | DO4 | Digital Output 4
45 | O | DO5 | Digital Output 5
46 | O | DO6 | Digital Output 6
47 | O | DO7 | Digital Output 7
48 | O | DO8 | Digital Output 8
49 | NC | NC | No Connection
50 | NC | NC | No Connection

Mating Connector Description: 50 pin 0.1" connector

Mating Connector Manufacturer: CW Industries

Mating Connector Manufacturer Part: 1C3AAG-5018M

1Other compatible connectors can be used.


6.0 PMX-2ED-SA Migration Quick Guide

CMD-2ED-SA Contoller ››

This page is currently under development. As we near release of the CMD-2ED-SA, check this page for the most current information.

When migrating from the PMX-2ED-SA, it is recommended to consider the CMD-2ED-SA.

PMX-2ED-SA

CMD-2ED-SA

The CMD-2ED-SA is designed to be backward compatible with the PMX-2ED-SA.

This page will display an example of a migration path from a PMX-2ED-SA to the CMD-2ED-SA.

For details of the differences between the CMD-2EX-SA and the PMX-2EX-SA review:

Hardware differences

Software differences

The full CMD-2ED-SA hardware manual can be found here . See the Commander Manual and the NPA Command Reference for command structure, operational details, firmware updates, software tools, and additional support resources.

A copy of the PMX-2ED-SA manual can be downloaded here .

Last updated Wednesday, July 22, 2026

Sign up for notices of updates on the Commander support site by filling out the form in this link .

https://support.nipponpulse.com/downloads/pmx/


6.1 Hardware

CMD-2ED-SA Contoller ›› 6.0 PMX-2ED-SA Migration Quick Guide ››

Hardware Differences

This page is currently under development. As the release of the CMD-2ED-SA gets closer this page will be updated with the most current information.

The CMD-2ED-SA was designed to be drop-in compatible with the PMX-2ED-SA

The enclosure style of the CMD-2ED-SA, are very close to the enclosures used of the PMX-2ED-SA. The CMD-2ED-SA are also pin to pin compatible to the PMX-2ED-SA. In most cases, no changes to mounting and connector locations, panel cutouts, brackets, or cable harnesses will be necessary.

Some new features are using pins which were labeled N/C in the PMX-2ED-SA. Please review the manual before connecting the CMD-2ED-SA to your system.

Stepper Motor Drivers:

The CMD-2ED-SA uses a more advanced stepper motor driver, Toshiba TB67S128FTG, which adds these features:

    • Motor Axis power LED and Enable LED added.
    • Microstepping can be set (full to 1/8) with jumpers on PCB for backwards compatiblity. If no microstepping jumpers are installed, microstepping (full to 1/128) can be set in the softwere and changed on-the-fly.
    • Jumper set current setting adjusted to match stepper motors from Nippon Pulse.
    • ON PCB Potentiometer added for custom current setting adjustment.
    • Position latching inputs were added to pin 20 (Latch X-axis) and pin 24 (Latch Y-axis) of the 50-Pin Connector Control/Encoder IO connector.

Last updated Wednesday, July 22, 2026


6.2 Software

CMD-2ED-SA Contoller ›› 6.0 PMX-2ED-SA Migration Quick Guide ››

Software Differences

This page is currently under development. As the release of the CMD-2ED-SA gets closer this page will be updated with the most current information.

The current goal is for the CMD-2ED-SA to be fully backward compatible with the PMX-2ED-SA.

A new PMX DLL is available, enabling your existing PMX software and command set to run on CMD hardware. In most cases, no application rewrite is required.

To access the new features available with the CMD-2ED-SA controllers, you will need to switch to the CMD DLL and software, which is more powerful and more flexible.

Last updated Wednesday, July 22, 2026


CMD-2EX-SA Controller

CMD-2EX-SA

Advanced 2-Axis

Stepper Motor Controller + Driver

CMD-2EX-SA

CMD-2EX-SA — 2-Axis Standalone Controller with Integrated Drivers

The CMD-2EX-SA is an advanced 2 axis stepper standalone programmable motion controller.

Communication to the CMD-2EX-SA can be established over USB or RS-485. It is possible to download a standalone program to the device and have it run independent of a host.

See the Commander Manual and the NPA Command Reference for command structure, operational details, firmware updates, software tools, and additional support resources.

Note: If you are migrating from the PMX-2EX-SA controller, see the Migration Quick Guide


1.0 Features

CMD-2EX-SA Controller ››

Features

  • USB 2.0 communication
  • RS-485 ASCII communication

9600, 19200, 38400, 57600, 115200 bps

  • Standalone programmable using A-SCRIPT
  • Advanced motion features
    • Trapezoidal or s-curve acceleration
    • On-the-fly speed change
    • XY linear coordinated motion
  • A/B/Z differential encoder inputs [Max frequency of 5 MHz]
    • StepNLoop closed loop control (position verification) -
      Opto-isolated I/O
    • 8 x inputs
    • +Limit/-Limit/Home inputs per axis -
      Homing routines:
      • Home input only
      • Limit only
      • Z-index encoder channel only
      • Home input + Z index encoder channel
        2 x 10-bit analog inputs
    • XYZU Joystick control


2.0 Electrical Specifications

CMD-2EX-SA Controller ››

Electrical Specifications

Parameter | Min | Max | Units
Main Power Input | +12 | +24 | V
 | - | 1.5 | A
Opto-supply Power Input | +12 | +24 | V
Pulse/Direction/Enable Open Collector | - | +24 | V
 | - | 40 | mA
Digital Input Forward Diode Current | - | 40 | mA
Digital Output Collector VOltage | - | +24 | V
Digital Output Sink Current | - | 90 | mA
Operating Temperature1 | -20 | +80 | °C
Storage Temperature1 | -55 | +150 | °C

1Based on component ratings


3.0 Dimensions

CMD-2EX-SA Controller ››

Dimensions

(Need image)


4.0 Pin Descriptions

CMD-2EX-SA Controller ››

Pin Descriptions

In order for CMD-2ED-SA to operate, it must be supplied with +12VDC to +24VDC.

In this section

  • 2-Pin Connector (5.08mm) – Controller Power
  • 3-Pin Connector (3.81mm) - RS485
  • 50-Pin Connector Control/Encoder IO
  • Interface Circuit
  • Limit, Home, and Digital Inputs
  • Digital Outputs
  • Encoder Input Connection
  • Analog Inputs


4.1 2-Pin Connector (5.08mm) – Controller Power

CMD-2EX-SA Controller ›› 4.0 Pin Descriptions ››

2-Pin Connector (5.08mm) – Controller Power

Pin # | In/Out | Name | Description
1 | I | G | Ground
2 | I | V+ | Power Input +12 to +24 VDC

Mating Connector Description: 2 pin 0.2” (5.08mm) connector

Mating Connector Manufacturer: On-Shore

Mating Connector Manufacturer Part: 1EDZ950/2

1 Other 5.08mm compatible connectors can be used.


4.2 3-Pin RS-485 Connector (3.81mm)

CMD-2EX-SA Controller ›› 4.0 Pin Descriptions ››

3-Pin RS-485 Connector (3.81mm)

Pin # | In/Out | Name | Description
1 | I/O | 485+ | RS-485 plus signal
2 | I/O | 485- | RS-485 minus signal
3 | I | G | Ground

Mating Connector Description: 3 pin 0.15” (3.81mm) connector

Mating Connector Manufacturer: On-Shore

Mating Connector Manufacturer Part: 1EDZ1550/3

1Other 3.81mm compatible connectors can be used.

(Need image)


4.3 50-Pin Connector /Encoder IO

CMD-2EX-SA Controller ›› 4.0 Pin Descriptions ››

50-Pin Control/Encoder IO

Pin # | In/Out | Name | Description
1 | NC | NC | No Connection
2 | NC | NC | No Connection
3 | O | +5V | +5V
4 | O | G | Ground
5 | I | AY | Y-Axis A Channel Encoder Input
6 | I | /AY | Y-Axis /A Channel Encoder Input
7 | I | BY | Y-Axis B Channel Encoder Input
8 | I | /BY | Y-Axis /B Channel Encoder Input
9 | I | ZY | Y-Axis Z Index Encoder Input
10 | I | /ZY | Y-Axis /Z Index Encoder Input
11 | NC | NC | No Connection
12 | NC | NC | No Connection
13 | NC | NC | No Connection
14 | NC | NC | No Connection
15 | NC | NC | No Connection
16 | NC | NC | No Connection
17 | NC | NC | No Connection
18 | NC | NC | No Connection
19 | NC | NC | No Connection
20 | NC | NC | No Connection
21 | O | +5V | +5V
22 | O | G | Ground
23 | I | AX | X-Axis A Channel Encoder Input
24 | I | /AX | X-Axis /A Channel Encoder Input
25 | I | BX | X-Axis B Channel Encoder Input
26 | I | /BX | X-Axis /B Channel Encoder Input
27 | I | ZX | X-Axis Z Index Encoder Input
28 | I | /ZX | X-Axis /Z Index Encoder Input
29 | NC | NC | No Connection
30 | NC | NC | No Connection
31 | NC | NC | No Connection
32 | NC | NC | No Connection
33 | NC | NC | No Connection
34 | NC | NC | No Connection
35 | NC | NC | No Connection
36 | NC | NC | No Connection
37 | NC | NC | No Connection
38 | NC | NC | No Connection
39 | O | +5V | +5V
40 | O | G | Ground
41 | O | PulX | X-Axis Pulse
42 | O | DirX | X-Axis Direction
43 | O | EnaX | X-Axis Enable
44 | I | AI1 | Analog Input 1
45 | O | PulY | Y-Axis Pulse
46 | O | DirY | Y-Axis Direction
47 | O | EnaY | Y-Axis Enable
48 | I | AI2 | Analog Input 2
49 | NC | NC | No Connection
50 | NC | NC | No Connection

Mating Connector Description: 50 pin 0.1" connector

Mating Connector Manufacturer: CW Industries

Mating Connector Manufacturer Part: 1C3AAG-5018M

1Other compatible IDC connectors can be used.


4.4 50-Pin Motion IO / DIO

CMD-2EX-SA Controller ›› 4.0 Pin Descriptions ››

50-Pin Motion IO / DIO

Pin # | In/Out | Name | Description
1 | NC | NC | No Connection
2 | NC | NC | No Connection
3 | I | Opto | Opto-Supply Input +12 to +24VDC
4 | NC | NC | No Connection
5 | I | +LX | +Limit [X Axis]
6 | I | -LZ | -Limit [X Axis]
7 | I | HX | Home [X Axis]
8 | NC | NC | No Connection
9 | I | +LY | +Limit [Y Axis]
10 | I | -LY | -Limit [Y Axis]
11 | I | HY | Home [Y Axis]
12 | NC | NC | No Connection
13 | NC | NC | No Connection
14 | NC | NC | No Connection
15 | NC | NC | No Connection
16 | NC | NC | No Connection
17 | NC | NC | No Connection
18 | NC | NC | No Connection
19 | NC | NC | No Connection
20 | NC | NC | No Connection
21 | NC | NC | No Connection
22 | NC | NC | No Connection
23 | NC | NC | No Connection
24 | NC | NC | No Connection
25 | NC | NC | No Connection
26 | NC | NC | No Connection
27 | NC | NC | No Connection
28 | NC | NC | No Connection
29 | I | Opto-Supply | Opto-Supply Input +12 to +24VDC
30 | I | Opto-Ground | Opto-Ground
31 | I | DI1 | Digital Input 1
32 | I | DI2 | Digital Input 2
33 | I | DI3 | Digital Input 3
34 | I | DI4 | Digital Input 4
35 | I | DI5 | Digital Input 5
36 | I | DI6 | Digital Input 6
37 | I | DI7 | Digital Input 7
38 | I | DI8 | Digital Input 8
39 | O | DO1 | Digital Output 1
40 | O | DO2 | Digital Output 2
41 | O | DO3 | Digital Output 3
42 | O | DO4 | Digital Output 4
43 | O | DO5 | Digital Output 5
44 | O | DO6 | Digital Output 6
45 | O | DO7 | Digital Output 7
46 | O | DO8 | Digital Output 8
47 | NC | NC | No Connection
48 | NC | NC | No Connection
49 | NC | NC | No Connection
50 | NC | NC | No Connection

Table 4.3

Mating Connector Description: 50 pin 0.1" connector

Mating Connector Manufacturer: CW Industries

Mating Connector Manufacturer Part: 1C3AAG-5018M

1Other compatible IDC connectors can be used.


4.5 Pulse, Direction, and Enable Outputs

CMD-2EX-SA Controller ›› 4.0 Pin Descriptions ››

Pulse, Direction, and Enable Outputs

The Pulse, Direction, and Enable outputs for both the standard and DB9 top boards are open collector outputs.

Schematic of these outputs. Each output is capable of sinking up to 40mA of current:

Figure 4.5

Example wiring diagram between the pulse, direction, and enable outputs on the PMX-2EX-SA and the corresponding input on a typical stepper driver:


4.6 Limit, Home, and Digital Inputs

CMD-2EX-SA Controller ›› 4.0 Pin Descriptions ››

Limit, Home, and Digital Inputs

Schematic of the opto-isolated limit, home, and general purpose digital inputs (All opto-isolated digital inputs are NPN type):

The opto-supply must be connected to +12 to +24VDC in order for the limit, home, and digital inputs to operate.

When the digital input is pulled to ground, current will flow from the opto-supply to ground, turning on the opto-isolator and activating the input.

To de-activate the input, the digital input should be left unconnected or pulled up to the opto-supply, preventing current from flowing through the opto-isolator.


4.7 Digital Outputs

CMD-2EX-SA Controller ›› 4.0 Pin Descriptions ››

Digital Outputs

Example wiring to the digital output (All opto-isolated digital outputs will be NPN type):

The opto-ground must be connected in order for the digital outputs to operate.

When activated, the opto-isolator for the digital output sinks the voltage on the digital output line to the opto-ground. The maximum sink current for digital outputs is 90mA. Take caution to select the appropriate external resistor so that the current does not exceed 90mA. Additionally, the pull up voltage should not exceed +24VDC.

When deactivated, the opto-isolator will break the connection between the digital output and the opto-ground. In this case, the voltage on the digital output signal will be the pull-up voltage.


4.8 Encoder Input Connection

CMD-2EX-SA Controller ›› 4.0 Pin Descriptions ››

Encoder Input Connection

Both single-ended and differential quadrature encoder inputs are accepted.

When using single-ended encoders, use the /A, /B, and /Z inputs.

+5V supply and Ground signals are available to power the encoder. Make sure the total current usage is less than 200mA for the +5V.

The maximum encoder frequency is 5MHz.


4.9 Analog Inputs

CMD-2EX-SA Controller ›› 4.0 Pin Descriptions ››

Analog Inputs

Analog inputs are 0 to 5V range and 10 bit in resolution. Using two analog inputs, joystick control can be achieved. Section 7.15 will provide details on joystick control.

The maximum source current for the analog inputs is 10mA.


5.0 PMX-2EX-SA Migration Quick Guide

CMD-2EX-SA Controller ››

This page is currently under development. As we near release of the CMD-2EX-SA, check this page for the most current information.

When migrating from the PMX-2EX-SA, it is recommended to consider the CMD-2EX-SA.

PMX-2EX-SA

CMD-2EX-SA

The CMD-2EX-SA is designed to be backward compatible with the PMX-2EX-SA.

This page will display an example of a migration path from a PMX-2EX-SA to the CMD-2EX-SA.

For details of the differences between the CMD-2EX-SA and the PMX-2EX-SA review:

Hardware differences

Software differences

The full CMD-2EX-SA hardware manual can be found here . See the Commander Manual and the NPA Command Reference for command structure, operational details, firmware updates, software tools, and additional support resources.

A copy of the PMX-2EX-SA manual can be downloaded here .

Last updated Wednesday, July 22, 2026

Sign up for notices of updates on the Commander support site by filling out the form in this link .


5.1 Hardware Differences

CMD-2EX-SA Controller ›› 5.0 PMX-2EX-SA Migration Quick Guide ››

Hardware Differences

This page is currently under development. As the release of the CMD-2EX-SA gets closer this page will be updated with the most current information.

The CMD-2EX-SA was designed to be drop-in compatible with the PMX-2EX-SA

The enclosure style of the CMD-2EX-SA, are very close to the enclosures used of the PMX-2EX-SA. The CMD-2EX-SA are also pin to pin compatible to the PMX-2EX-SA. In most cases, no changes to mounting and connector locations, panel cutouts, brackets, or cable harnesses will be necessary.

Some new features are using pins which were labeled N/C in the PMX-2EX-SA. Please review the manual before connecting the CMD-2EX-SA to your system.

Hardware differences between the CMD-2ED-SA and PMX-2ED-SA.

Stepper Motor Drivers:

1. CMD-2ED-SA used a more advanced stepper motor driver, Toshiba TB67S128FTG, which addes the following features

-

2. Motor Axis power LED and Enable LED added.

3. Micro-stepping can be set (full to 1/8) with jumpers on PCB for backwards compatiblity. If no microstepping jumpers are installed, microstepping (full to 1/128) can be set in the softwere and changed on-the-fly.

4. Jumper set current setting adjusted to match stepper motors from Nippon Pulse.

5. On PCB Potentiometer added for custom current setting adjustment.

6. Position latching inputs were added to pin 20 (Latch X-axis) and pin 24 (Latch Y-axis) of the 50-Pin Connector Control/Encoder IO connector.

Last updated Wednesday, July 22, 2026


5.2 Software

CMD-2EX-SA Controller ›› 5.0 PMX-2EX-SA Migration Quick Guide ››

Software Differences

This page is currently under development. As the release of the CMD-2EX-SA gets closer this page will be updated with the most current information.

The current goal is for the CMD-2EX-SA to be fully backward compatible with the PMX-2EX-SA.

A new PMX DLL is available, enabling your existing PMX software and command set to run on CMD hardware. In most cases, no application rewrite is required.

To access the new features available with the CMD-2EX-SA controllers, you will need to switch to the CMD DLL and software, which is more powerful and more flexible.

Last updated Wednesday, July 22, 2026


CMD-4EX-SA Contoller

The CMD-4EX-SA is a next-generation, advanced 4-axis stepper/servo standalone programmable motion controller from Nippon Pulse. It is part of the Standalone Controller series within the Commander Ecosystem, built on the proven Commander motion control core.

Designed for flexibility and ease of integration, the CMD-4EX-SA supports communication over USB or RS-485 and can execute downloaded programs independently, eliminating the need for a host PC during operation.

The CMD-4EX-SA is available with multiple top board configurations:

  • TBB / TBS: Controller-only configurations (no integrated motor drivers)
  • TBD: Controller with integrated stepper motor drivers

This manual provides detailed information on the mechanical and electrical specifications of the CMD-4EX-SA. For command structure and operational details, refer to the Commander Manual and the NPA Command Reference.

For firmware updates, software tools, and additional support resources: Commander Online Manual

This manual covers the mechanical and electrical specifications related to the CMD-4EX-SA. For more information regarding the command set and operations, see the Commander manual and NPA Command Reference . For additional support-related documentation regarding firmware updates and the available software, see https://support.nipponpulse.com/ .

Note: If you are migrating from the PMX-4EX-SA controller, see the Migration Quick Guide

Features

Model Numbers

Top Board Options

Supporting Parts

IO Breakout board (JBD-4EX-I26)

40-Pin IO cable (210-130-01)

Din Rail Mounting Kit (KIT-4EX-DIN)

Base Plate (300-300-01)

Replacement Connectors

For use with CMD-4EX-SA-TBD controller

2-Pin Motor Power cable (210-244-01)

Stepper Motors for TBD

Communication Interface

USB Communication

Serial Communication

Dimensions

CMD-4EX-SA-TB_(With Top Board)

CMD-4EX-SA (Standalone)

JBD-4EX-I26

Connectivity

CMD-4EX-SA

2-PIN Logic power connector

3-PIN RS-485 connector

USB connector

10-PIN DIO connector (High speed Input/Output)

40-PIN DIO connector (I/O Expansion Connector)

CMD-4EX-SA Standalone Version

Top Board

Safety and Encoder inputs

14-PIN Motion Input Connector

8-PIN Encoder Input Connectors

TBB connections

10-PIN TBB Axis Connectors

TBD connections

2-PIN TBD Power Connectors

4-PIN TBD Axis Connectors

TBS connections

8-PIN TBS Axis Connectors

JBD-4EX-I26

10-PIN J3 General I/O (1-10) connector

10-PIN J2 General I/O (11-20) connector

8-PIN J4 General I/O (21-26 Opto power) connector

8-PIN J5 SD, E-Stop, Ext Start connector

8-PIN J6 Analog In/Out J6_2 (Joystick) connector

40-PIN DIO connector (I/O Expansion Connector)

Interface circuit

Electrical and Thermal Specifications

Contact Information

Note: If you are migrating from the PMX-2ED-SA controller, see the Migration Quick Guide


1.0 Features

CMD-4EX-SA Contoller ››

The CMD-4EX-SA is based on the PCL6045BL motion control LSI and an ARM Core processor.

Power

  • +12VDC to +48VDC power input / Logic
  • +12VDC to +24VDC motor power
  • 3.3V logic level, 5V tolerant

Communication

  • USB 2.0, HID compatible. No driver signature required
  • RS-485 ASCII, selectable 9600, 19200, 38400, 57600, 115200 baud rates available
  • Ethernet, available for future expansion

Control

  • Command control from PC through USB or serial communication
  • Standalone control allows operation separate from PC, using a BASIC-like programming language known as A-SCRIPT

Utility software

  • Allows for operation check by utility software
  • Compile, write and read standalone programs

Motor interface

  • Maximum pulse output rate of 6.55M PPS
  • Stepper motor interface with pulse, direction, and enable outputs for XYZU
  • Servo motor interface with pulse, direction, enable, in-position, servo alarm, and error clear outputs for XYZU

Homing Routines

  • 13 different built-in homing routines available, high speed and low speed.

Positioning operations

  • Selectable trapezoidal or s-curve acceleration
  • High-speed correction function for short movements
  • Absolute positioning or incremental positioning can be selected
  • On-the-fly speed change (speed overridden during movement).
  • On-the-fly target position change (target position overridden during movement).
  • Coordinated motion
    • Linear (XYZU) (2 to 4 axis)
    • Circular/Arc (any two axes)
    • Helix/Tangential (XYZ)
    • Continuous linear/circular/arc coordinated buffered move for XYZ axis
  • Control using manual pulse generator (MPG)
    • Electronic camming
    • Electronic gearing

Inputs/Outputs

  • With integrated noise filter, to reduce switch bounce
  • A/B/Z encoder inputs for XYZU (TTL Compatible)
    • Maximum frequency of 6.5 MHz (26M counts with 4x Multiplication)
    • StepNLoop closed-loop position verification algorithm (XYZU)
  • Manual pulse generator (MPG) operation
    • A/B pulse inputs for XYZU (TTL Compatible)
    • Maximum frequency of 6.5 MHz (26M counts with 4x Multiplication)
  • Digital I/O
    • 4 designated high-speed inputs
    • 4 designated high-speed outputs
    • +Limit/-Limit/Home inputs for XYZU
    • Simultaneous start input
    • Emergency stop input
    • 32 configurable I/O
    • Latching input
    • Synchronization Pulse output
  • Analog I/O
    • Two 10-bit analog input
    • Two PWM outputs
    • Joystick operation with analog input (X-axis, Y-axis)

Stepper Motor Driver ( TBD )

  • Directly drive 4 bipolar stepper motors
  • PWM-controlled constant-current drive
  • Low on-resistance MOSFET output stage
  • Stepping resolutions of full, half, quarter, 1/8, 1/16, 1/32, 1/64, and 1/128 step
  • High-efficiency motor current control mechanism ( ADMD: Advanced Dynamic Mixed Decay )
  • Built-in anti-stall architecture ( AGC: Active Gain Control )
  • Motor drive voltage 12 to 24Vdc
  • Motor current 0.19A to 2.3A
  • Multi error detection functions:
    • Thermal shutdown (TSD)
    • Over-current (ISD)
    • Motor load open (OPD)

Firmware upgrade and download via USB using NPA firmware loader software .


2.0 Model Numbers

CMD-4EX-SA Contoller ››

Chart showing woe to build part number

The CMD-4EX-SA is an advanced four-axis stepper/servo standalone programmable motion controller. It consist of two main parts:

  • The base board, which contains the power, communication, and input/output interface (both high speed and general I/O). The base board has a motion connector for connection to a top breakout PCB.
    • The base board includes the Commander core (CMD-4CR) motion controller.
  • The top board is used as an interface PCB between the motion controller and your motors. Nippon Pulse has a number of standard top boards , or a custom top board can be supplied that meets your unique needs.
  • When selecting a TBD top board, the current rating for the drivers must be stated.


2.1 Top Board Options

CMD-4EX-SA Contoller ›› 2.0 Model Numbers ››

The CMD-4EX-SA is available with a variety of standard top board configurations. The top board should be selected based on your interfacing needs.

All standard top boards constant of 3.81mm screw terminals for home, limits, and encoder inputs.

Picture of CMD-4EX-SA-TBB

The balanced line driver output version ( TBB ) consists of 3.81mm screw terminals for X/Y/Z/U pulse/dir/enable/error clear outputs and alarm/in-position inputs. In this version only Pulse and Direction outputs are balanced line driver output.

Picture of CMD-4EX-SA-TBD

The stepper motor driver output version ( TBD ) consists of 4 axis 2.3A 128-micro-step stepper motor drivers with Molex Mini-Fit Jr connectors for the motor connections. The current settings for the drivers can be set using jumpers, when using Nippon Pulse series stepper motors , or with an adjustment port for other motors. Micro-stepping can be changed on the fly with the MSR command (I/O30 to I/O32).

The TBD drivers use ADMD and AGC technology that optimizes the drive current in real-time, improving efficiency, saving energy, and significantly reducing heat dissipation in the motor and driver.

Picture of CMD-4EX-SA-TBS

The open collector output version ( TBS ) consists of 3.81mm screw terminals for X/Y/Z/U pulse/dir/enable/error clear outputs and alarm/in-position inputs.

OEM versions

Custom Top Board

There is also an option for Nippon Pulse to design a custom top board to meet the unique needs for your application. Contact Nippon Pulse for more information.


3.0 Supporting parts

CMD-4EX-SA Contoller ››

Nippon Pulse offers the following supporting products for CMD-4EX-SA series of controllers. Click the links below for more information:

IO Breakout board (JBD-4EX-I26)

40-Pin IO cable (210-130-01)

Din Rail Mounting Kit (KIT-4EX-DIN)

Base Plate (300-300-01)

Replacement Connectors

For use with CMD-4EX-SA-TBD controller

2-Pin Motor Power cable (210-244-01)

Stepper Motors for TBD


3.1 IO Breakout board (JBD-4EX-I26)

CMD-4EX-SA Contoller ›› 3.0 Supporting parts ››

The JBD-4EX-I26 is a breakout PCB for the 40-PIN DIO connector (I/O Expansion Connector) of the CMD-4EX-SA. It adds input/output protection to the 26 configurable I/O. All outputs can be set to current sinking or current sourcing independently. The JPD-4EX-I26 is supplied with a mounting back plate and a 40-Pin IO cable (210-130-01) . Click on any connector in the image below for more information (Help file and web only).

Picture of the top of JBD-4EX-I26 Picture of the back of JBD-4EX-I26


3.2 40-Pin IO cable (210-130-01)

CMD-4EX-SA Contoller ›› 3.0 Supporting parts ››

Replacement 40 pin cable for connecting the JBD-4EX-I26 40-PIN DIO connector (I/O Expansion Connector) to the CMD-4EX-SA 40-PIN DIO connector (I/O Expansion Connector) . Length is 300mm (11.8 in).

Picture of 210-130-01


3.3 Din Rail Mounting Kit (KIT-4EX-DIN)

CMD-4EX-SA Contoller ›› 3.0 Supporting parts ››

The Din Rail Mounting Kit (KIT-4EX-DIN) makes it possible to din rail mount the CMD-4EX-SA series of controllers.

Picture of KIT-4EX-DIN

Picture of the Bottom of the CMD-4EX-SA > Picture of KIT-4EX-DIN > Picture showing the CMD-4EX-SA with KIT-4EX-DIN > Picture showing the CMD-4EX-SA with KIT-4EX-DIN and Din Rail


3.4 Base Plate (300-300-01)

CMD-4EX-SA Contoller ›› 3.0 Supporting parts ››

The 300-300-01 Base Plate is an optional mounting base for the CMD-4EX-SA (standalone) and JBD-4EX-I26. Below are some examples of how the 300-300-01 base plate can be used.

Picture of 300-300-01 Base

When used with the CMD-4EX-SA (standalone)

CMD-4EX-SA mounted on 300-300-01

When used with the JBD-4EX-I26

JBD-4EX-I26 mounted on 300-300-01

When used on a custom stack-up

Custom Stack on 300-300-01


3.5 2-Pin Motor Power cable (210-244-01)

CMD-4EX-SA Contoller ›› 3.0 Supporting parts ››

Two-pin power cable for connecting motor power to the 2-PIN TBD Power Connector on the CMD-4EX-SA-TBD. Length is 430mm (17 in).

Picture of 210-255-01


3.6 Stepper Motors for TBD

CMD-4EX-SA Contoller ›› 3.0 Supporting parts ››

Nippon Pulse has a full line of stepper motors that work work seamlessly with the TBD option on the CMD-4EX-SA. The below motors are available with flying leads to be wired in to your product or with connectors that plug directly in to the CMD-4EX-SA-TBD. Contact Nippon Pulse or your local representative for more information.

Rotary

Photo of a PJE20T

PJE20T

Part #

NEMA size

Step angle

Holding torque

PJE20T -28E14

8

1.8 deg. / step

22 mN•m

PJE20T -40E14

8

1.8 deg. / step

38 mN•m

Photo of a PJE28T

PJE28T

PJE28T -32E14

11

1.8 deg. / step

80 mN•m

PJE28T -40E14

11

1.8 deg. / step

120 mN•m

PJE28T -51E14

11

1.8 deg. / step

120 mN•m

Photo of a PJE35T

PJE35T

PJE35T -26E14

14

1.8 deg. / step

70 mN•m

PJE35T -37E14

14

1.8 deg. / step

180 mN•m

PJE35T -53E14

14

1.8 deg. / step

310 mN•m

Photo of a PJE42T

PJE42T

PJE42T -34D14

17

1.8 deg. / step

300 mN•m

PJE42T -40D14

17

1.8 deg. / step

400 mN•m

PJE42T -48A14-E1000

17

1.8 deg. / step

480 mN•m

PJE42T -48D14

17

1.8 deg. / step

530 mN•m

Linear

Part #

NEMA size

Step distance

Thrust

PJPL28

Photo of a PJPL28

PJPL28

11

0.005 mm / step

50 N

Photo of a PJPL28T

PJPL28T

11

0.01 mm / step

0.005 mm / step

25 N

50 N

PJPL42

Photo of a PJPL42

PJPL42

17

0.005 mm / step

225 N

Photo of a PJPL42T

PJPL42T

17

0.01 mm / step

0.005 mm / step

80 N


3.7 DMX-A2-DRV

CMD-4EX-SA Contoller ›› 3.0 Supporting parts ››

High Resolution Integrated Stepper Motor + Microstep Driver + (Encoder)

The DMX-A2-DRV is an integrated step motor and driver product designed to work with the TB9 Version top board. It is available with or without an encoder. This allows for simple fast setup and prototyping.

Features:

12 to 48 VDC voltage input

100mA to 3.0A current setting

2-500 micro-step

1M maximum pulse rate input support

Opto-isolated Pulse/Dir (CW/CCW) and Enable inputs

Opto-isolated over-temperature alarm output

Available in NEMA 23 in double and triple stack lengths

Available with 1000 count encoder (-E100).

Software configurable

Programming cable DMX-CFG-USB-A2


3.8 Replacement Connectors

CMD-4EX-SA Contoller ›› 3.0 Supporting parts ››

If you need replacement connectors, they can be ordered from Nippon Pulse or a local electronics supplier.

Mating Connector

Description: 2 pin 0.2” (5.08mm) connector

Manufacturer: On-Shore

Manufacturer Part: EDZ950/2

NPA part number: 430-402-10

Note: Other 5.08mm compatible connectors can also be used.

Description: 3 pin 0.15” (3.81mm) connector

Manufacturer: On-Shore

Manufacturer Part: EDZ1550/3

NPA part number: 430-303-10

Note: Other 3.81mm compatible connectors can be used.

Description: 8 pin 0.15” (3.81mm) connector

Manufacturer: On-Shore

Manufacturer Part: EDZ1550/8

NPA part number: 430-308-01

Note: Other 3.81mm compatible connectors can be used.

Description: 10 pin 0.15” (3.81mm) connector

Manufacturer: On-Shore

Manufacturer Part: EDZ1550/10

NPA part number: 430-310-10

Note: Other 3.81mm compatible connectors can be used.

Description: 14 pin 0.15” (3.81mm) connector

Manufacturer: On-Shore

Manufacturer Part: EDZ1550/14

NPA part number: 430-314-01

Note: Other 3.81mm compatible connectors can be used.


4.1 CMD-4EX-SA-TB_ (With Top Board)

CMD-4EX-SA Contoller ›› 4.0 Dimensions ››

CMD-4EX-SA-TBB is shown in the figure below. All mounting dimensions are the same for all versions (TBB, TBD and TBS). Dimension (A), which is different depending on the version selected, is listed in a table below.

Model | Dimension (A)
CMD-4EX-SA-TBB | 38.8
CMD-4EX-SA-TBD | 42.4
CMD-4EX-SA-TBS | 38.8
CMD-4EX-SA-TB9 | 38.8

All dimensions are in mm [inch] and for reference only.


4.2 CMD-4EX-SA (Standalone)

CMD-4EX-SA Contoller ›› 4.0 Dimensions ››

The CMD-4EX-SA (Standalone version) dimensions are shown in the figure below.


4.3 JBD-4EX-I26

CMD-4EX-SA Contoller ›› 4.0 Dimensions ››

The JBD-4EX-I26 dimensions are shown in the figure below.


5.0 Connectivity

CMD-4EX-SA Contoller ››

Click on the connector below for more information.

Front

Side

Standalone

TBB

TBD

TBD Current Settings

TBS

I26

USBRS485Power In

High speed I/OGeneral I/O

Motion InputsEncoder inputsAxis connectors

Motion inputsEncoder inputsMotor OutputsMotor Power

Current Settings for CMD-4EX-SA-TBD Current AdjustCurrent Jumper settings

Motion InputsEncoder InputsAxis Outputs

J3 IO1-IO10IO1 to IO10IO1 to IO10IO11 to IO20IO11 to IO20IO11 to IO20J2 IO11 to IO20IO21 to IO26IO21 to IO26IO21 to IO26J4 IO21 to IO26 Opto PowerJ5 SD, E-Stop, External StartJ6_2 JoystickJ6 Analog In/OutJ1 Input IO Expantion

General I/OHigh Speed I/OLogic PowerRS-485USBJ7 interfaceCommanderUSB Hub


5.1 2-PIN Logic power connector

CMD-4EX-SA Contoller ›› 5.0 Connectivity ››

Picture showing location of power input.

Pin description:

Pin # | In/Out | Name | Description | I/F circuit
1 | I | GND | Ground |
2 | I | V+ | Power Input +12 to +48 VDC

Mating Connector

Description: 2 pin 0.2” (5.08mm) connector

Manufacturer: On-Shore

Manufacturer Part: EDZ950/2

NPA part number: 430-402-10

Note: Other 5.08mm compatible connectors can also be used.


5.2 3-PIN RS-485 connector

CMD-4EX-SA Contoller ›› 5.0 Connectivity ››

Picture showing location of RS-485 input

Pin description:

Pin # | In/Out | Name | Description | I/F circuit
1 | I/O | - | RS-485 minus signal | RS-485
2 | I/O | + | RS-485 plus signal
3 | I | G | Ground

Mating Connector

Description: 3 pin 0.15” (3.81mm) connector

Manufacturer: On-Shore

Manufacturer Part: EDZ1550/3

NPA part number: 430-303-10

Note: Other 3.81mm compatible connectors can be used.


5.3 USB connector

CMD-4EX-SA Contoller ›› 5.0 Connectivity ››

Picture showing location of USB input

Pin description:

Pin # | In/Out | Name | Description | I/F circuit
1 | I | VBUS | USB Power | USB
2 | I/O | D- | D- differential data signal
3 | I/O | D+ | D- differential data signal
4 |  | GND | USB Ground

Mating Connector

Description: USB Type B connector

Note: Since the USB cable can be a source of USB communication issues, Nippon Pulse suggests using USB cables that have noise suppression choke installed. For more information see USB Communication.


5.4 10-PIN DIO connector (High speed Input/Output)

CMD-4EX-SA Contoller ›› 5.0 Connectivity ››

Picture showing location of high speed input/output

Pin description:

Pin # | In/Out | Name | Description | I/F circuit
1 | O | DO1/SYNCx | Digital Output 1 | HSO
2 | O | DO2/SYNCy | Digital Output 2
3 | O | DO3/SYNCz | Digital Output 3
4 | O | DO4/SYNCu | Digital Output 4
5 | I | DI1/LTCx | Digital Input 1 [Latch X] | HSI
6 | I | DI2/LTCy | Digital Input 2 [Latch Y]
7 | I | DI3/LTCz | Digital Input 3[ Latch Z]
8 | I | DI4/LTCu | Digital Input 4 [Latch U]
9 | I | VS | Opto-Supply +12 to +24 VDC | OPI
10 | I | VG | Opto-Ground

Mating Connector

Description: 10 pin 0.15” (3.81mm) connector

Manufacturer: On-Shore

Manufacturer Part: EDZ1550/10

NPA part number: 430-310-10

Note: Other 3.81mm compatible connectors can be used.


5.5 40-PIN DIO connector (I/O Expansion Connector)

CMD-4EX-SA Contoller ›› 5.0 Connectivity ››

Picture showing location of general input/output

Pin description:

Pin # | In/Out | Name | Description | I/F circuit
1 | O | VCC | Power Output +5 VDC @ 250mA |
2 | I | \CSTA | Simultaneous Start | BGI
3 | I/O | IO2 | General-purpose, configurable I/O 2 | BIO
4 | I/O | IO1 | General-purpose, configurable I/O 1
5 | I/O | IO4 | General-purpose, configurable I/O 4
6 | I/O | IO3 | General-purpose, configurable I/O 3
7 | I/O | IO6 | General-purpose, configurable I/O 6
8 | I/O | IO5 | General-purpose, configurable I/O 5
9 | I/O | IO8 | General-purpose, configurable I/O 8
10 | I/O | IO7 | General-purpose, configurable I/O 7
11 | I/O | IO10 | General-purpose, configurable I/O 10
12 | I/O | IO9 | General-purpose, configurable I/O 9
13 | I/O | IO12 | General-purpose, configurable I/O 12
14 | I/O | IO11 | General-purpose, configurable I/O 11
15 | I/O | IO14 | General-purpose, configurable I/O 14
16 | I/O | IO13 | General-purpose, configurable I/O 13
17 | I/O | IO16 | General-purpose, configurable I/O 16
18 | I/O | IO15 | General-purpose, configurable I/O 15
19 | I/O | IO18 | General-purpose, configurable I/O 18
20 | I/O | IO17 | General-purpose, configurable I/O 17
21 | I/O | IO20 | General-purpose, configurable I/O 20
22 | I/O | IO19 | General-purpose, configurable I/O 19
23 | I/O | IO22 | General-purpose, configurable I/O 22
24 | I/O | IO21 | General-purpose, configurable I/O 21
25 | I/O | IO24 | General-purpose, configurable I/O 24
26 | I/O | IO23 | General-purpose, configurable I/O 23
27 | I/O | IO26 | General-purpose, configurable I/O 26
28 | I/O | IO25 | General-purpose, configurable I/O 25
29 | I | SDx | Slow Down Axis X | BGI
30 | I | SDy | Slow Down Axis Y
31 | I | SDz | Slow Down Axis Z
32 | I | SDu | Slow Down Axis U
33 | I | AIN2 | Analog in 2 | BIO
34 | I | AIN1 | Analog in 1
35 | O | AOUT2 | Analog out 2 | P2A
36 | O | AOUT1 | Analog out 1
37 | O | VCC | Power Output +5 VDC @ 250mA | 5PO
38 | O | GND | Ground |
39 | I | \CEMG | E-Stop | BGI
40 | I | RST | Reset | IBI

Mating Connector

Description: 40 pin 0.039” (1.0mm) connector

Manufacturer: JST Sales America Inc.

Manufacturer Part: SHDR-40V-S-B

Note: Mating cable ( 210-130-01 ) supplied with JBD-4EX-I26 adapter card. Also available separately.


6.0 CMD-4EX-SA Standalone Version

CMD-4EX-SA Contoller ›› 5.0 Connectivity ››

Picture showing location of J7 58pin header

J7 is an 58-pin connector used to pass signals up to various top boards. These signals are either unused (TBS does not take pins 1, 2, 53-58) or go to a top board. These 58 pins are not designed to touch the outside world directly, so no additional protection is present. Pins 53 to 58 are general IO pins, and are protected the same way that all other IO pins are.

Pin description:

Pin # | In/Out | Name | Description | I/F circuit
1 | I/O | D+ | D+ differential data signal | USB Hub
2 | I/O | D- | D- differential data signal
3 | O | PULx | Pulse [X Axis] | OCO
4 | O | DIRx | Direction [X Axis]
5 | I | +Lx | +Limit [X Axis] | BGI
6 | I | -Lx | -Limit [X Axis]
7 | I | Hx | Home [X Axis]
8 | I | INPx | In-Position [X Axis]
9 | O | EOx | Enable [X Axis] | OCO
10 | I | EAx | A Channel Encoder Input [X Axis] | BGI
11 | I | EBx | B Channel Encoder Input [X Axis]
12 | I | EZx | Z Index Encoder Input [X Axis]
13 | I | ALMx | Servo Alarm [X Axis]
14 | O | ERCx | Error Clear [X Axis] | OCO
15 | O | PULy | Pulse [Y Axis]
16 | O | DIRy | Direction [Y Axis]
17 | I | +Ly | +Limit [Y Axis] | BGI
18 | I | -Ly | -Limit [Y Axis]
19 | I | Hy | Home [Y Axis]
20 | I | INPy | In-Position [Y Axis]
21 | O | EOy | Enable [Y Axis] | OCO
22 | I | EAy | A Channel Encoder Input [Y Axis] | BGI
23 | I | EBy | B Channel Encoder Input [Y Axis]
24 | I | EZy | Z Index Encoder Input [Y Axis]
25 | I | ALMy | Servo Alarm [Y Axis]
26 | O | ERCy | Error Clear [Y Axis] | OCO
27 | O | PULz | Pulse [Z Axis]
28 | O | DIRz | Direction [Z Axis]
29 | I | +Lz | +Limit [Z Axis] | BGI
30 | I | -Lz | -Limit [Z Axis]
31 | I | Hz | Home [Z Axis]
32 | I | INPz | In-Position [Z Axis]
33 | O | EOz | Enable [Z Axis] | OCO
34 | I | EAz | A Channel Encoder Input [Z Axis] | BGI
35 | I | EBz | B Channel Encoder Input [Z Axis]
36 | I | EZz | Z Index Encoder Input [Z Axis]
37 | I | ALMz | Servo Alarm [Z Axis]
38 | O | ERCz | Error Clear [Z Axis] | OCO
39 | O | PULu | Pulse [U Axis]
40 | O | DIRu | Direction [U Axis]
41 | I | +Lu | +Limit [U Axis] | BGI
42 | I | -Lu | -Limit [U Axis]
43 | I | Hu | Home [U Axis]
44 | I | INPu | In-Position [U Axis]
45 | O | EOu | Enable [U Axis] | OCO
46 | I | EAu | A Channel Encoder Input [U Axis] | BGI
47 | I | EBu | B Channel Encoder Input [U Axis]
48 | I | EZu | Z Index Encoder Input [U Axis]
49 | I | ALMu | Servo Alarm [U Axis]
50 | O | ERCu | Error Clear [U Axis] | OCO
51 | O | VCC | Power Output +5 VDC @ 250mA | 5PO
52 | O | GND | Ground |
53 | I/O | IO27 | General-purpose, configurable I/O 27 | BIO
54 | I/O | IO28 | General-purpose, configurable I/O 28
55 | I/O | IO29 | General-purpose, configurable I/O 29
56 | I/O | IO30 | General-purpose, configurable I/O 30
57 | I/O | IO31 | General-purpose, configurable I/O 31
58 | I/O | IO32 | General-purpose, configurable I/O 32

Mating Connector

Description: 58 pin 0.1” (2.54mm) header

Manufacturer: Samtec, Inc.

Manufacturer Part: TSW-129

Note: Other 2.54mm compatible headers can be used. Length of pin will be dependent on your application.


7.1 14-PIN Motion Input Connector

CMD-4EX-SA Contoller ›› 5.0 Connectivity ›› 7.0 Motion/Encoder ››

Pin description:

Pin # | In/Out | Name | Description | I/F circuit
1 | I | VG | Ground | OPI
2 | I | VS | Opto-Supply Input +12 to +24 VDC (for limit and home inputs)
3 | I | -Lu | -Limit [U Axis] | OI
4 | I | Hu | Home [U Axis]
5 | I | +Lu | +Limit [U Axis]
6 | I | -Lz | -Limit [Z Axis]
7 | I | Hz | Home [Z Axis]
8 | I | +Lz | +Limit [Z Axis]
9 | I | -Ly | -Limit [Y Axis]
10 | I | Hy | Home [Y Axis]
11 | I | +Ly | +Limit [Y Axis]
12 | I | -Lx | -Limit [X Axis]
13 | I | Hx | Home [X Axis]
14 | I | +Lx | +Limit [X Axis]

Mating Connector

Description: 14 pin 0.15” (3.81mm) connector

Manufacturer: On-Shore

Manufacturer Part: EDZ1550/14

NPA part number: 430-314-01

Note: Other 3.81mm compatible connectors can be used.


7.2 8-PIN Encoder/MPG Input Connectors

CMD-4EX-SA Contoller ›› 5.0 Connectivity ›› 7.0 Motion/Encoder ››

Pin description:

Pin # | In/Out | Name | Description | I/F circuit
1 | O | GND | Ground |
2 | O | VCC | Power Output +5 VDC @ 200mA all outputs | 5PO
3 | I | /Z | /Z Index Encoder Input | DEI
4 | I | Z | Z Index Encoder Input
5 | I | /B | /B Channel Encoder / MPG Input
6 | I | B | B Channel Encoder / MPG Input
7 | I | /A | /A Channel Encoder / MPG Input
8 | I | A | A Channel Encoder / MPG Input

MPG input

The MPG inputs on the CMD-4EX-SA are paralleled to the Encoder inputs as outlined in the table below.

Encoder Input | MPG Input
X axis encoder input | Y axis MPG input
Y axis encoder input | Z axis MPG input
Z axis encoder input | U axis MPG input
U axis encoder input | X axis MPG input

Mating Connector

Description: 8 pin 0.15” (3.81mm) connector

Manufacturer: On-Shore

Manufacturer Part: EDZ1550/8

NPA part number: 430-308-01

Note: Other 3.81mm compatible connectors can be used.


8.0 TBB 10-PIN TBB Axis Connectors

CMD-4EX-SA Contoller ›› 5.0 Connectivity ››

Click on the picture below to learn more about the connection.

Motion InputsEncoder inputsAxis connectors

10-PIN TBB Axis Connectors

CMD-4EX-SA-TBB Motion Outputs

Pin description:

Pin # | In/Out | Name | Description | I/F circuit
1 | O | GND | Ground |
2 | O | V+ | Power Output +5 VDC @ 250mA total | 5PO
3 | I | Alarm | Servo Alarm | OI
4 | I | INP | In-Position
5 | O | ERC | Error Clear | OCO
6 | O | Enable | Enable out
7 | O | DIR+ | Direction + | DMO
8 | O | DIR- | Direction -
9 | O | PUL+ | Pulse Out +
10 | O | PUL- | Pulse Out -

Mating Connector

Description: 10 pin 0.15” (3.81mm) connector

Manufacturer: On-Shore

Manufacturer Part: EDZ1550/10

NPA part number: 430-310-10

Note: Other 3.81mm compatible connectors can be used.


9.0 TBD

CMD-4EX-SA Contoller ›› 5.0 Connectivity ››

Click on the picture below to learn more about the connection.

Motion inputsEncoder inputsMotor OutputsMotor Power

2-PIN TBD Motor Power Connectors

4-PIN TBD Axis Connectors

Motor Driver output


2-PIN TBD Motor Power Connectors

CMD-4EX-SA Contoller ›› 5.0 Connectivity ›› 9.0 TBD ››

Pin description:

Pin # | In/Out | Name | Description | I/F circuit
1 | I | V+ | Power Input +12 to +24 VDC | MPI
2 | I | GND | Ground |

Mating Connector

Description: 2 pin 0.165" (4.20mm) connector

Manufacturer: Molex

Manufacturer Part: Housings 0039013022 Pins 0039000181

NPA part number: 2-Pin Motor Power cable ( 210-244-01 )

Note: Other 2-pin Mini-Fit Jr 5557 connectors can be used.


4-PIN TBD Axis Connectors

CMD-4EX-SA Contoller ›› 5.0 Connectivity ›› 9.0 TBD ››

Motor Driver output

Pin numbering:

Motor out pin numbering

Pin description:

Pin # | In/Out | Name | Description
1 | O | A+ | Bi-polar Step Motor – Phase A
2 | O | B+ | Bi-polar Step Motor – Phase B
3 | O | A- | Bi-polar Step Motor – Phase /A
4 | O | B- | Bi-polar Step Motor – Phase /B

Mating Connector

Description: 4 pin 0.165" (4.20mm) connector

Manufacturer: Molex

Manufacturer Part: Housings 0039012040 Pins 0039000181

NPA part number: Supplied on Stepper Motors

Note: Other 4-pin Mini-Fit Jr 5557 connectors can be used.


10.0 TBS 8-PIN TBS Axis Connectors

CMD-4EX-SA Contoller ›› 5.0 Connectivity ››

Click on the picture below to learn more about the connection.

Motion InputsEncoder InputsAxis Outputs

8-PIN TBS Axis Connectors

TBS Axis connectors

Pin description:

Pin # | In/Out | Name | Description | I/F circuit
1 | O | GND | Ground |
2 | O | V+ | Power Output +5 VDC | 5PO
3 | I |  | Servo Alarm | OI
4 | I |  | In-Position
5 | O |  | Error Clear | OCO
6 | O |  | Enable out
7 | O |  | Direction
8 | O |  | Pulse Out

Mating Connector

Description: 8 pin 0.15” (3.81mm) connector

Manufacturer: On-Shore

Manufacturer Part: EDZ1550/8

NPA part number: 430-308-01

Note: Other 3.81mm compatible connectors can be used.


12.0 I26

CMD-4EX-SA Contoller ›› 5.0 Connectivity ››

Click on the pictures below to learn more about the connection.

J3 IO1-IO10IO1 to IO10IO1 to IO10IO11 to IO20IO11 to IO20IO11 to IO20J2 IO11 to IO20IO21 to IO26IO21 to IO26IO21 to IO26J4 IO21 to IO26 Opto PowerJ5 SD, E-Stop, External StartJ6_2 JoystickJ6 Analog In/OutJ1 Input IO Expantion Picture of the back of JBD-4EX-I26


10-PIN J3 General I/O (1-10) connector

CMD-4EX-SA Contoller ›› 5.0 Connectivity ›› 12.0 I26 ››

JBD-4EX-I26 IO1 to IO10

Pin description:

Pin # | In/Out | Name | Description | I/F circuit
10 | I/O | IO1 | General configurable I/O 1 | Jumper set to IN OII Jumper set to OUT and Config to Source OSRC Jumper set to OUT and Config to Sinking OSNK
9 | I/O | IO2 | General configurable I/O 2
8 | I/O | IO3 | General configurable I/O 3
7 | I/O | IO4 | General configurable I/O 4
6 | I/O | IO5 | General configurable I/O 5
5 | I/O | IO6 | General configurable I/O 6
4 | I/O | IO7 | General configurable I/O 7
3 | I/O | IO8 | General configurable I/O 8
2 | I/O | IO9 | General configurable I/O 9
1 | I/O | IO10 | General configurable I/O 10

Note:

IN/OUT Jumper should match IOCFG setting. Output configuration resistors are set for sinking current by default.

Mating Connector

Description: 10 pin 0.138" (3.5mm) connector

Manufacturer: On-Shore

Manufacturer Part: OSTTJ1011530

NPA part number: 430-410-10

Note: Other 3.81mm compatible connectors can be used.


10-PIN J2 General I/O (11-20) connector

CMD-4EX-SA Contoller ›› 5.0 Connectivity ›› 12.0 I26 ››

JBD-4EX-I26 IO11 to IO20

Pin description:

Pin # | In/Out | Name | Description | I/F circuit
10 | I/O | IO11 | General configurable I/O 11 | Jumper set to IN OII Jumper set to OUT and Config to Source OSRC Jumper set to OUT and Config to Sinking OSNK
9 | I/O | IO12 | General configurable I/O 12
8 | I/O | IO13 | General configurable I/O 13
7 | I/O | IO14 | General configurable I/O 14
6 | I/O | IO15 | General configurable I/O 15
5 | I/O | IO16 | General configurable I/O 16
4 | I/O | IO17 | General configurable I/O 17
3 | I/O | IO18 | General configurable I/O 18
2 | I/O | IO19 | General configurable I/O 19
1 | I/O | IO20 | General configurable I/O 20

Note:

IN/OUT Jumper should match IOCFG setting. Output configuration resistors are set for sinking current by default.

Mating Connector

Description: 10 pin 0.138" (3.5mm) connector

Manufacturer: On-Shore

Manufacturer Part: OSTTJ1011530

NPA part number: 430-410-10

Note: Other 3.81mm compatible connectors can be used.


8-PIN J4 General I/O (21-26 Opto power) connector

CMD-4EX-SA Contoller ›› 5.0 Connectivity ›› 12.0 I26 ››

JBD-4EX-I26 IO21 to IO26

Pin description:

Pin # | In/Out | Name | Description | I/F circuit
8 | I/O | IO21 | General configurable I/O 21 | Jumper set to IN OII Jumper set to OUT and Config to Source OSRC Jumper set to OUT and Config to Sinking OSNK
7 | I/O | IO22 | General configurable I/O 22
6 | I/O | IO23 | General configurable I/O 23
5 | I/O | IO24 | General configurable I/O 24
4 | I/O | IO25 | General configurable I/O 25
3 | I/O | IO26 | General configurable I/O 26
2 | I | VS | Opto-Supply +12 to +48 VDC | OPI
1 | I | VG | Opto-Ground

Note:

IN/OUT Jumper should match IOCFG setting. Output configuration resistors are set for sinking current by default.

Mating Connector

Description: 8 pin 0.138" (3.5mm) connector

Manufacturer: On-Shore

Manufacturer Part: OSTTJ0811530

NPA part number: 430-408-10

Note: Other 3.81mm compatible connectors can be used.


8-PIN J5 SD, E-Stop, Ext Start connector

CMD-4EX-SA Contoller ›› 5.0 Connectivity ›› 12.0 I26 ››

Pin description:

Pin # | In/Out | Name | Description | I/F circuit
8 | O | VCC | Power Output +5 Vdc |
7 | O | GND | Ground |
6 | I | SDx | Slow Down Axis X | BGI
5 | I | SDy | Slow Down Axis Y
4 | I | SDz | Slow Down Axis Z
3 | I | SDu | Slow Down Axis U
2 | I | /CEMG | E-Stop
1 | I | /CSTA | Simultaneous Start

Note:

Limit the current out from all VCC (+5Vdc) output to 250mA.

Mating Connector

Description: 8 pin 0.138" (3.5mm) connector

Manufacturer: On-Shore

Manufacturer Part: OSTTJ0811530

NPA part number: 430-408-10

Note: Other 3.81mm compatible connectors can be used.


8-PIN J6 Analog In/Out J6_2 (Joystick) connector

CMD-4EX-SA Contoller ›› 5.0 Connectivity ›› 12.0 I26 ››

Pin description:

Pin # | In/Out | Name | Description | I/F circuit
1 | O | VCC | Power Output +5 Vdc | 5PO
2 | O | GND | Ground |
3 | I | AIN1 | Analog in 1 | BIO
4 | I | AIN2 | Analog in 2
5 | O | AOUT1 | Analog output 1 | PWM to Analog RC
6 | O | AOUT2 | Analog output 2
7 | N/C | N/C | Reserved |
8 | N/C | N/C | Reserved |

Note:

Limit the current out from all VCC (+5Vdc) output to 250mA.

Analog out is controlled using the PWM[1-2] command. PWM1 controls AOUT1, PWM2 controls AOUT2.

J6_2 is used for Joystick connection.

Mating Connector

J6

Description: 8 pin 0.138" (3.5mm) connector

Manufacturer: On-Shore

Manufacturer Part: OSTTJ0811530

NPA part number: 430-408-10

Note: Other 3.81mm compatible connectors can be used.

J6_2

Description: 8 pin 0.1" (2.54mm) header

Note: Any 2.54mm compatible header can be used.


40-PIN DIO connector (I/O Expansion Connector)

CMD-4EX-SA Contoller ›› 5.0 Connectivity ›› 12.0 I26 ››

Pin description:

Pin # | In/Out | Name | Description
40 | O | VCC | Power Output +5 VDC @ 250mA
39 | I | \CSTA | Simultaneous Start
38 | I/O | IO2 | General-purpose, configurable I/O 2
37 | I/O | IO1 | General-purpose, configurable I/O 1
36 | I/O | IO4 | General-purpose, configurable I/O 4
35 | I/O | IO3 | General-purpose, configurable I/O 3
34 | I/O | IO6 | General-purpose, configurable I/O 6
33 | I/O | IO5 | General-purpose, configurable I/O 5
32 | I/O | IO8 | General-purpose, configurable I/O 8
31 | I/O | IO7 | General-purpose, configurable I/O 7
30 | I/O | IO10 | General-purpose, configurable I/O 10
29 | I/O | IO9 | General-purpose, configurable I/O 9
28 | I/O | IO12 | General-purpose, configurable I/O 12
27 | I/O | IO11 | General-purpose, configurable I/O 11
26 | I/O | IO14 | General-purpose, configurable I/O 14
25 | I/O | IO13 | General-purpose, configurable I/O 13
24 | I/O | IO16 | General-purpose, configurable I/O 16
23 | I/O | IO15 | General-purpose, configurable I/O 15
22 | I/O | IO18 | General-purpose, configurable I/O 18
21 | I/O | IO17 | General-purpose, configurable I/O 17
20 | I/O | IO20 | General-purpose, configurable I/O 20
19 | I/O | IO19 | General-purpose, configurable I/O 19
18 | I/O | IO22 | General-purpose, configurable I/O 22
17 | I/O | IO21 | General-purpose, configurable I/O 21
16 | I/O | IO24 | General-purpose, configurable I/O 24
15 | I/O | IO23 | General-purpose, configurable I/O 23
14 | I/O | IO26 | General-purpose, configurable I/O 26
13 | I/O | IO25 | General-purpose, configurable I/O 25
12 | I | SDx | Slow Down Axis X
11 | I | SDy | Slow Down Axis Y
10 | I | SDz | Slow Down Axis Z
9 | I | SDu | Slow Down Axis U
8 | I | AIN2 | Analog in 2
7 | I | AIN1 | Analog in 1
6 | O | AOUT2 | Analog out 2
5 | O | AOUT1 | Analog out 1
4 | O | VCC | Power Output +5 VDC @ 250mA
3 | O | GND | Ground
2 | I | \CEMG | E-Stop
1 | O | GND | Ground

Mating Connector

Description: 40 pin 0.039” (1.0mm) connector

Manufacturer: JST Sales America Inc.

Manufacturer Part: SHDR-40V-S-B

Note: Mating cable ( 210-130-01 ) supplied with JBD-4EX-I26 adapter card. Also available separately.


Electrical Specifications

CMD-4EX-SA Contoller ››
Parameter | Min | Max | Units
Main Power Input | +12 | +48 | V
 | - | 2.0 | A
Opto-supply Power Input | +12 | +24 | V
Driver Power Input 1 | +12 | +48 | V
 | - | 3.0 | A
Pulse / Direction / Enable Open Collector 2 | - | +24 | V
 | - | 40 | mA
Alarm Input Forward Diode Current | - | 40 | mA
Digital Input Forward Diode Current | - | 40 | mA
Digital Output Source Current | - | 90 | mA
Operating Temperature 3 | -20 | +80 | °C
Storage Temperature 3 | -55 | +150 | °C

1 Only applicable to the TB9 top board option. Current requirement is dependent on the driver settings.

2 Only applicable to the TBS and TB9 top board options.

3 Based on component rating


PMX-4EX-SA Migration Quick Guide

CMD-4EX-SA Contoller ››

This page is currently under development. Check this page for updates and the most current information.

When migrating from the PMX-4EX-SA-TBS, it is recommended to consider the CMD-4EX-SA-TBS.

PMX-4EX-SA-TBS

CMD-4EX-SA-TBS

The CMD-4EX-SA is available with multiple top board configurations :

• TBB / TBS : Controller-only configurations (no integrated motor drivers)

• TBD : Controller with integrated stepper motor drivers

The CMD-4EX-SA is designed to be partially backward compatible with the PMX-4EX-SA. The CMD-4EX-SA keeps existing simplicity, connectors, pin outs, and software compatibility of the PMX-4EX-SA, with additional robustness and advanced features that users have requested. Due to physical size limitations the number of quick access inputs/outputs has been reduced to 4 high speed inputs and 4 high speed outputs. An additional 26 general purpose configurable inputs/outputs are available.

This page will display an example of a migration path from a PMX-4EX-SA-TBS to the CMD-4EX-SA-TBS.

For details of the differences between the CMD-4EX-SA and the PMX-4EX-SA review:

Hardware differences

Software differences

The full CMD-4EX-SA hardware manual can be found here . See the Commander Manual and the NPA Command Reference for command structure, operational details, firmware updates, software tools, and additional support resources.

A copy of the PMX-4EX-SA manual can be downloaded here .

Last updated Wednesday, July 22, 2026

Sign up for notices of updates on the Commander support site by filling out the form in this link .


Hardware Differences

CMD-4EX-SA Contoller ›› PMX-4EX-SA Migration Quick Guide ››

This page is currently under development. As the release of the CMD-4EX-SA gets closer this page will be updated with the most current information.

At this time, we do not have a fully backwards compatible path for the PMX-4EX-SA-TBS to the CMD-4EX-SA-TBS.

Dimensions

The CMD-4EX-SA series uses enclosure styles similar to PMX-4EX-SA series, with changes to mounting and connector locations. Panel cutouts, brackets, and cable harnesses may require adjustment. Please review the CMD-4EX-SA mechanical drawings before finalizing your migration.

The outside and mounting dimensions are different. The CMD-4EX-SA-TBB is shown in the figure below. All mounting dimensions are the same for all versions (TBB, TBD and TBS). Dimension (A), which is different depending on the version selected, is listed in a table below.

PMX-4EX-SA-TBS CMD-4EX-SA-TBx

Model | Dimension (A)
CMD-4EX-SA-TBB | 38.8
CMD-4EX-SA-TBD | 42.4
CMD-4EX-SA-TBS | 38.8
CMD-4EX-SA-TB9 | 38.8

All dimensions are in mm [inch] and for reference only.

Power input

The PMX-4EX-SA-TBS accepts +12 to +24Vdc and the CMD-4EX-SA-TBS has a larger voltage input range of +12V to +48Vdc. The power input connector and polarity remain the same.

Commutation RS485

Both the PMX-4EX-SA-TBS and CMD-4EX-SA-TBS support RS485 commutation, and use the same connector. The pin-out of the RS485 connector has changes between the two.

Picture showing location of RS-485 input

PMX-4EX-SA-TBS CMD-4EX-SA-TBx

Analog input output

The PMX-4EX-SA-TBS had 8 analog input and 0 analog output connections on the front of the unit.

The CMD-4EX-SA-TBS has 2 analog input and 2 analog output connections acceptable from the 40-PIN DIO connector (I/O Expansion Connector) or on J6 of the JBD-4EX-I26 breakout board .

The analog input voltage range on the PMX was 0 to 5Vdc. The analog input voltage range on the CMD is 0 to 3.3Vdc.

Digital input output

The CMD-4EX-SA series has a higher total number of inputs/outputs available, but due to physical size limitations the number of quick access inputs/outputs has been reduced to 4 high speed inputs and 4 high speed outputs . An additional 26 general purpose configurable inputs/outputs are available.

Picture showing location of high speed input/output

PMX-4EX-SA-TBS CMD-4EX-SA-TBx

All inputs and outputs on the PMX-4EX-SA-TBS are opto isolated and rated for 400kHz

On the CMD-4EX-SA the high speed inputs and outputs are opto-isolated. Inputs rated at 400kHz, outputs rated for 1.25MHz

Schematic of High speed input

The 26 general purpose I/O is 3V3 logic, at the 40 pin I/O connector and opto-isolated when used with the optional JBD-4EX-I26 breakout board.

Motion input

The motion inputs (+limit, home, -limit) have the same pin-out for both the PMX-4EX-SA-TBS and CMD-4EX-SA-TBS. Both are opto isolated, while the PMX used a 3K current limit the CMD uses a 2Kohm current limit.

Schematic of Opto-isolated input

PMX-4EX-SA-TBS CMD-4EX-SA-TBx

Encoder input

The encoder inputs are fully compatible between the PMX-4EX-SA-TBS and the CMD-4EX-SA-TBS.

Axis connection

The axis connections are fully compatible between the PMX-4EX-SA-TBS and the CMD-4EX-SA-TBS.

Last updated Wednesday, July 22, 2026


Software

CMD-4EX-SA Contoller ›› PMX-4EX-SA Migration Quick Guide ››

Software Differences

This page is currently under development. As the release of the CMD-4EX-SA gets closer this page will be updated with the most current information.

At this time, we do not have a fully backwards compatible path for the PMX-4EX-SA-TBS to the CMD-4EX-SA-TBS.

A new PMX DLL is available, enabling your existing PMX software and command set to run on CMD hardware. However, because of input/output differences between the PMX-4EX-SA-TBS and the CMD-4EX-SA-TBS, any software you have written may need to be adjusted accordingly. For many projects, minable rewrite software adjustments may be required.

To access the new features available with the CMD-4EX-SA controllers, you will need to switch to the CMD DLL and software, which is more powerful and more flexible.

Last updated Wednesday, July 22, 2026


Motor Current Settings

The CMD-4EX-SA-TBD, and CMD-2ED-SA have built-in micro-stepping drivers, allowing the controller to directly drive bipolar stepper motors. These controllers use an advanced stepper motor driver, Toshiba TB67S128FTG, which adds these features:

  • PWM-controlled constant-current drive.
  • Low on-resistance MOSFET output stage.
  • Stepping resolutions of full, half, quarter, 1/8, 1/16, 1/32, 1/64, 1/128 step, and can be set in the software and changed on-the-fly.
  • High-efficiency motor current control mechanism ( ADMD: Advanced Dynamic Mixed Decay )
  • Built-in anti-stall architecture ( AGC: Active Gain Control )
  • Motor drive voltage 12 to 24Vdc
  • Motor current 0.19A to 2.3A
    • Jumper set current setting adjusted to match stepper motors from Nippon Pulse.
    • On PCB Potentiometer added for custom current setting adjustment.
  • Multi error detection functions:
    • Thermal shutdown (TSD)
    • Overcurrent (ISD)
    • Motor load open (OPD)


Microstepping

Motor Current Settings ››

Micro-stepping divides a stepper motor step into many smaller parts, producing a smoother and less noisy motor rotation. Stepper motors can have a jerky motion and produce much noise at lower speeds, micro-stepping can smooth out this jerkiness and quiet down the noise.

The CMD-4EX-SA-TBD and CMD-2ED-SA has 8 micro-stepping resolutions, as outlined in the table below. Even while the motor is in motion, the micro-stepping resolution can be changed. The CMD-4ED and CMD-2ED firmwares adds the MSR command to simplify the setting of the micro-stepping resolution to a single command. The CMD-4CR and CMD-2CR firmware can adjust the resolution by setting IO30, IO31, and IO32, as shown in the chart below.

MSR | Setting | IO30 | IO31 | IO32
0 | Full Step | 0 | 0 | 0
1 | 1/2 step | 1 | 0 | 0
2 | 1/4 step | 0 | 1 | 0
3 | 1/8 step | 1 | 1 | 0
4 | 1/16 step | 0 | 0 | 1
5 | 1/32 step | 1 | 0 | 1
6 | 1/64 step | 0 | 1 | 1
7 | 1/128 step | 1 | 1 | 1

The number of micro-steps per revolution is calculated by the following equation: "DEGREE" is the full step angle of the motor, and "USTEP" is the micro-stepping resolution.

µstep revolution = 360 / (DEGREE * USTEP)

For example, using a 1.8° motor and a micro-stepping resolution of 1/8, the number of micro-steps/revolution would be [360° / (1.8° * 1/8)] = 1600


Setting Driver Current CMD-4EX-SA-TBD

Motor Current Settings ››

The CMD-4EX-SA-TBD was designed to work seamlessly with stepper motors supplied by Nippon Pulse. When ordering the CMD-4EX-SA-TBD, you can define the current settings for each axis to match the Nippon Pulse stepper motors you have selected. It is also possible to change the current settings at a later date.

The CMD-4EX-SA-TBD contains a series of jumpers to configure the driver current settings.

To set the current, follow these steps:

  1. Disconnect all power and cables from the CMD-4EX-SA-TBD.

Picture of CMD-4EX-SA-TBD

  2. Remove the 4 screws from the top cover and lift the cover straight up.

Top cover screw locations

  3. Remove the 4 screws from the TBD board, then lift the TBD board straight up.

TBD screw locations

  4. Flip the TBD board over, and you will see the jumpers on the edge closest to the power connector.

Location of Jumpers

  5. Move the jumper to the location corresponding to the current setting needed.

If none of the predefined current ranges will meet your needs, set the jumper to position 9,10 (ADJ) and use the potentiometer on the top of the TBD board to set the correct current.

Adjustable jumpers and pot locations

  6. Reinstall the TBD board into the CMD-4EX-SA. Ensure the 58pin header is installed and seated correctly. Install the 4 screws to the TBD board.

  7. Verify that the 58pin header is mating correctly and that the TBD board is sitting flat on the standoffs.
  8. If you used a predefined current setting. Go-to step 16.
  9. If you need to set the driver to a current not predefined, calculate the required Vref value using the formula to the right:

You can set Vref to any value between 0.24V and 2.68V.

Vref = Iout / 0.78
  10. Connect 12Vdc to 24Vdc to the motor power in. The LED next to the power input connector and the LED next to each motor connector should light up.

  11. Set the voltmeter to DC voltage and to the proper scale (around 3 V).

  12. Place the voltmeter probes on the correct test points for the driver you will be setting. Black to GND test point and Red to Vref test point.
  13. Use a screwdriver to adjust the corresponding potentiometer to the value we calculated in step 9.

  14. Repeat steps 9 to 13 for each axis for which the current must be set.
  15. Remove the power and other cables from the CMD-4EX-SA-TBD.
  16. Install the top cover back on the CMD-4EX-SA-TBD, and install the 4 screws securing the cover.


Setting Driver Current CMD-2ED-SA

Motor Current Settings ››

The CMD-2ED-SA-TBD was designed to work seamlessly with stepper motors supplied by Nippon Pulse. It is also possible to change the current settings as outlined below.

The CMD-2ED-SA contains a series of jumpers to configure the driver current settings.

To set the current, follow these steps:

  1. Disconnect all power and cables from the CMD-4EX-SA-TBD.

Picture of CMD-4EX-SA-TBD

  2. Remove the 4 screws from the top cover and lift the cover straight up.

Top cover screw locations

  3. Remove the 4 screws from the TBD board, then lift the TBD board straight up.

TBD screw locations

  4. Flip the TBD board over, and you will see the jumpers on the edge closest to the power connector.

Location of Jumpers

  5. Move the jumper to the location corresponding to the current setting needed.

If none of the predefined current ranges will meet your needs, set the jumper to position 9,10 (ADJ) and use the potentiometer on the top of the TBD board to set the correct current.

Adjustable jumpers and pot locations

  6. Reinstall the TBD board into the CMD-4EX-SA. Ensure the 58pin header is installed and seated correctly. Install the 4 screws to the TBD board.

  7. Verify that the 58pin header is mating correctly and that the TBD board is sitting flat on the standoffs.
  8. If you used a predefined current setting. Go-to step 16.
  9. If you need to set the driver to a current not predefined, calculate the required Vref value using the formula to the right:

You can set Vref to any value between 0.24V and 2.68V.

Vref = Iout / 0.78
  10. Connect 12Vdc to 24Vdc to the motor power in. The LED next to the power input connector and the LED next to each motor connector should light up.

  11. Set the voltmeter to DC voltage and to the proper scale (around 3 V).

  12. Place the voltmeter probes on the correct test points for the driver you will be setting. Black to GND test point and Red to Vref test point.
  13. Use a screwdriver to adjust the corresponding potentiometer to the value we calculated in step 9.

  14. Repeat steps 9 to 13 for each axis for which the current must be set.
  15. Remove the power and other cables from the CMD-4EX-SA-TBD.
  16. Install the top cover back on the CMD-4EX-SA-TBD, and install the 4 screws securing the cover.


Advanced Dynamic Mixed Decay (ADMD) Technology

Motor Current Settings ››

Conventional Mixed Decay:Missed step at high rpm / ADMD Technology:Precise microstep control even at high rpm ADMD technology tracks input current more closely than the conventional mixed-decay mode, making highly efficient motor control possible at high rpm.


Active Gain Control (AGC) Technology

Motor Current Settings ››

AGC technology optimizes the drive current in real-time.

MPEG movie player required: lib/AGC.mp4

In conventional technologies, the motor control drivers generally supply a motor drive current greater than the peak current required by the maximum load to provide sufficient margin for the motor torque. This extra current continuously flows, resulting in excess heat generated on the driver and motor. As an option, a sensor or a microcontroller can monitor the changes in the load conditions, thereby adjusting the motor drive current according to the load conditions. This feedback process requires extremely complicated control. The closed-loop current control system can minimize unnecessary current consumption but adds additional cost.

The CMD-4EX-SA-TBD uses motor driver ICs incorporating AGC technology, which senses a motor's load torque and automatically optimizes the motor drive current. The AGC technology makes it possible to prevent a motor from going out of step while simplifying high-efficiency motor control.

Improving efficiency, saving energy, and significantly reducing heat dissipation in the motor without adding additional cost:

Improving efficiency, saving energy, and significantly reducing heat dissipation in a motor

AGC technology automatically adjusts the motor drive current according to a motor's load conditions to reduce extra current, thereby considerably reducing the amount of heat generated by the motor driver IC and the motor. This helps reduce overall heat generation in a system and the resulting degradation.


Communication Interface

Communication Interface

CMD-standalone controllers have several communication options. The default method is USB communication, though Serial Communication and Ethernet communication are also available.

More information about the Commander series communication is available in the Commander Communication Manual .

USB Communication

Serial Communication


USB Communication

Communication Interface ››

CMD-standalone controllers are HID devices and is USB 2.0 compliant. The The controllers have a built-in USB hub that allows it to connect to the motion core, and to select top boards.

Motion core

No additional USB drivers are needed to communicate with the motion core. All USB communication to the motion core is done using an ASCII command protocol.

Top board

No top board design currently makes use of the USB communication.

More information about the Commander series communication is available in the Commander Communication manual .

In this section

USB Communication

Serial Communication


Serial Communication

Communication Interface ››

The CMD-4EX-SA has the ability to communicate over a RS-485 serial communication interface with the motion core using an ASCII protocol. This allows for a simple, half-duplex, bi-direction multi-drop network using a single twisted pair.

Below is the detailed schematic of the RS-485 communication line input.

Schematic:

Notes:

  • For setup of the RS485 input, see the Commander Communication manual .

Protection:

ESD Protection

Bi-directional TVS from signal to

ground, and TVS between A and B.

Applies to:

Picture showing location of RS-485 input


Interface Circuit

Interface Circuit

(Need new image)


LPI - Logic Power Input

Interface Circuit ››

LPI - Logic Power Input

Schematic of Main Power input filter


Input Circuit

Interface Circuit ››

Input Circuit

On this page

  • Limit, Home, and Digital Inputs
  • Analog Inputs
  • Encoder Input Connection

Limit, Home, and Digital Inputs

Schematic of the opto-isolated limit, home, and general purpose digital inputs (All opto-isolated digital inputs are NPN type):

The opto-supply must be connected to +12 to +24VDC in order for the limit, home, and digital inputs to operate.

When the digital input is pulled to ground, current will flow from the opto-supply to ground, turning on the opto-isolator and activating the input.

To de-activate the input, the digital input should be left unconnected or pulled up to the opto-supply, preventing current from flowing through the opto-isolator.

Analog Inputs

Analog inputs are 0 to 5V range and 10 bit in resolution. Using two analog inputs, joystick control can be achieved. Section 7.15 will provide details on joystick control.

The maximum source current for the analog inputs is 10mA.

Encoder Input Connection

Both single-ended and differential quadrature encoder inputs are accepted.

When using single-ended encoders, use the /A, /B, and /Z inputs.

+5V supply and Ground signals are available to power the encoder. Make sure the total current usage is less than 200mA for the +5V.

The maximum encoder frequency is 5MHz.


Output Circuit

Interface Circuit ››

Digital Outputs

Example wiring to the digital output (All opto-isolated digital outputs will be NPN type):

The opto-ground must be connected in order for the digital outputs to operate.

When activated, the opto-isolator for the digital output sinks the voltage on the digital output line to the opto-ground. The maximum sink current for digital outputs is 90mA. Take caution to select the appropriate external resistor so that the current does not exceed 90mA. Additionally, the pull up voltage should not exceed +24VDC.

When deactivated, the opto-isolator will break the connection between the digital output and the opto-ground. In this case, the voltage on the digital output signal will be the pull-up voltage.


Power

Interface Circuit ››


LPI - Logic Power Input

Interface Circuit ›› Power ››

Below is the detailed schematic of the Logic Power input.

Schematic:

Schematic of Main Power input filter

Notes:

  • The logic power input was designed to operate between 12Vdc to 48Vdc. It offers ESD protection, Reverse voltage, Over-voltage/Transients, and current limiting.

Applies to:

2-PIN Logic Power

Picture showing location of power input.


OPI - Opto Power Inputs

Interface Circuit ›› Power ››

Below is the detailed schematic of the Opto-power input lines.

Schematic:

Schematic of the Opto-power input

Notes:

The opto-power inputs are individuality filtered. +12 to +24 VDC. Ensure that opto-power voltage does not exceed 24VDC.

Applies to:

14-PIN Motion Input Connector Pin 1 and 2

10-PIN DIO connector (High speed Input/Output) Pin 9 and 10

Picture showing location of high speed input/output

8-PIN J4 General I/O (21-26 Opto power) connector Pin 1 and 2

JBD-4EX-I26 IO21 to IO26


5PO - 5Vdc power output

Interface Circuit ›› Power ››

Below is the detailed schematic of the 5V+ power output lines.

Schematic:

Schematic 5Vdc out

Notes:

The 5V output pins are individually fused. Ensure that total current usage from all 5V outputs is less than 1000mA.

Protection:

ESD Protection | Current Limit | Over voltage/Transients | Reverse Polarity
N/A | 250mA imposed by self re-settable fuse | N/A | N/A

Applies to:

All 5V out pins.

40-PIN DIO connector (I/O Expansion Connector) Pin 37

Picture showing location of general input/output

8-PIN Encoder Input Connectors Pin 2

10-PIN TBB Axis Connectors Pin 2

CMD-4EX-SA-TBB Motion Outputs

CMD-4EX-SA J7 Pin 51

Picture showing location of J7 58pin header


MPI - Motor Power Input

Interface Circuit ›› Power ››

Below is the detailed schematic of the Motor Power input.

Schematic:

Schematic of Motor power input

Notes:

  • The main power input was designed to operate between 12Vdc to 24Vdc. It offers Reverse voltage, and Over-voltage/Transients limiting.

Applies to:

2-PIN Motor Power


HSI - High speed input

Interface Circuit ›› Input Circuit ››

Below is the detailed schematic of the opto-isolated high speed digital inputs. All opto-isolated digital inputs are NPN type.

Schematic:

Schematic of High speed input

Notes:

  • The opto-supply (pin 9 of 10 pin I/O connector ) must be connected to at least +12VDC, but not exceed +48VDC, in order for the digital inputs to operate at maximum efficiency.
  • When a digital input is pulled to ground, current will flow from the opto-supply to ground, and the opto-isolator will then power on and activate the corresponding input(s).
  • To deactivate the input, a digital input should be left unconnected or switched back to the opto-supply. This will stop current from flowing through the opto-isolator to ground.

Applies to:

10-PIN DIO connector (High speed Input/Output) Pins 5 to 8

Picture showing location of high speed input/output


BGI - Buffered general input

Interface Circuit ›› Input Circuit ››

Below is the detailed schematic of the buffered digital inputs.

Schematic:

Schematic of buffered digital input

Notes:

The buffered digital inputs are designed to work with open collector (sinking) or TTL logic outputs. When connecting a TTL output, ensure the logic voltage is 5V.

When a digital input is pulled to ground, current will flow from the internal power supply to ground.

To deactivate the input, a digital input should be left unconnected or switched back to the logic supply. This will stop current from flowing.

Applies to:

40-PIN DIO connector (I/O Expansion Connector) Pins 2, 29-32, 39

Picture showing location of general input/output

CMD-4EX-SA J7 Pins 5-8, 10-13, 17-20, 22-25, 29-32, 34-37, 41-44, 46-49

Picture showing location of J7 58pin header


IBI - Inverted Buffered input

Interface Circuit ›› Input Circuit ››

Below is the detailed schematic of the inverted buffered digital inputs.

Schematic:

Schematic of inverted buffered input

Notes:

The inverted buffered digital inputs are designed to work with open collector (Sourcing) or TTL logic outputs. When connecting a TTL output, ensure the logic voltage is at least 5V.

When this digital input is pulled up (sourcing), current will flow from the external power supply through the internal 4.7K resister ground. Ensure that supply voltage is 48V or less and current is limited to 11mA or less.

To deactivate the input, the digital input should be left unconnected or switched back to ground.

Applies to:

Reset input - 40-PIN DIO connector (I/O Expansion Connector) Pins 40

Picture showing location of general input/output


OI - Opto-isolated input

Interface Circuit ›› Input Circuit ››

Below is the detailed schematic of the opto-isolated digital inputs. All opto-isolated digital inputs are NPN type.

Schematic:

Schematic of Opto-isolated input

Notes:

  • The opto-supply must be connected to at least +12VDC, but not exceed +48VDC, in order for the opto-isolated digital inputs to operate.
  • When a digital input is pulled to ground, current will flow from the opto-supply to ground, and the opto-isolator will then power on and activate the corresponding input(s).
  • To deactivate the input, a digital input should be left unconnected or switched back to the opto-supply. This will stop current from flowing through the opto-isolator to ground.

Applies to:

14-PIN Motion Input Connector Pin 3 to 14

10-PIN TBB Axis Connectors Pins 3 and 4

CMD-4EX-SA-TBB Motion Outputs

8-PIN TBS Axis Connectors Pins 3 and 4

TBS Axis connectors


OII - Opto-isolated input

Interface Circuit ›› Input Circuit ››

Below is the detailed schematic of the opto-isolated digital inputs. All opto-isolated digital inputs are NPN type.

Schematic:

Schematic of Opto-isolated input

Notes:

  • The opto-supply (pin 2 of J4 8 pin I/O connector ) must be connected to at least +12VDC, but not exceed +48VDC, in order for the digital inputs to operate at maximum efficiency.
  • When a digital input is pulled to ground, current will flow from the opto-supply to ground, and the opto-isolator will then power on and activate the corresponding input(s).
  • To deactivate the input, a digital input should be left unconnected or switched back to the opto-supply. This will stop current from flowing through the opto-isolator to ground.

Applies to:

JBD-4EX-I26 general I/O pin configured as input.


DEI - Differential Encoder input

Interface Circuit ›› Input Circuit ››

Below is the detailed schematic of the Differential Encoder inputs.

Schematic:

Schematic of Differential Encoder Inputs

Notes:

The differential encoder inputs are designed to work with differential or single ended encoders. When connecting a single ended encoder, connect it to the - input, and leave the + input unconnected.

The signal is then set to the Encoder input and MPG input.

Applies to:

8-PIN Encoder Input Connectors Pins 3-8


HSO - High speed output

Interface Circuit ›› Output Circuit ››

Below is the detailed schematic of the opto-isolated high speed digital output.

Schematic:

Notes:

The opto-supply (pin 9 of 10 pin I/O connector ) must be connected to at least +12VDC, but not exceed +48VDC, in order for the digital outputs to operate.

Applies to:

10-PIN DIO connector (High speed Input/Output) Pins 1 to 4

Picture showing location of high speed input/output


OCO - Open collector outputs

Interface Circuit ›› Output Circuit ››

Below is the detailed schematic of the open collector digital outputs. All digital outputs are NPN type.

Schematic:

Schematic of the open collector output

Notes:

All open collector outputs are each capable of sinking up to 40mA of current.

Example wiring:

Example of wiring to an open collector output.

Applies to:

10-PIN TBB Axis Connectors Pins 5 and 6

CMD-4EX-SA-TBB Motion Outputs

8-PIN TBS Axis Connectors Pins 5-8

TBS Axis connectors

CMD-4EX-SA J7 Pins 3, 4, 9, 14-16, 21, 26-28, 33, 38-40, 45, 50

Picture showing location of J7 58pin header


OSRC - Open collector output Sourcing

Interface Circuit ›› Output Circuit ››

Below is the detailed schematic of the open collector digital output, which is configured as current sourcing.

Schematic:

Schematic of Sourcing current Open collector

Notes:

The open collector output is current limited by the internal current limiting resistor. Use the following formula to understand the maximum current that can be sourced:

Vopto / 4700 = Iout

Vopto : the opto voltage input

Iout : the maximum current that will flow in Amps, then the output is shorted to opto gnd.

Actual current may be lower based on the external circuit connected.

Example wiring:

Example of connection to OSRC

Applies to:

JBD-4EX-I26 general I/O pin configured as sourcing and output.

I/O Config for source current


OSNK - Open collector outputs

Interface Circuit ›› Output Circuit ››

Below is the detailed schematic of the open collector digital output, which is configured as current sourcing.

Schematic:

Schematic of Sink open collector

Notes:

The open collector output is current limited by the internal current limiting resistor. Use the following formula to understand the maximum current that can be sunk:

Vopto / 4700 = Iout

Vopto : the opto voltage input

Iout : the maximum current that will flow in Amps when the output is shorted to opto+V.

Actual current may be lower based on the external circuit connected.

Example wiring:

Example of open collector sink

Applies to:

JBD-4EX-I26 general I/O pins configured as sinking and output.

I/O Config for Sinking current


DMO - Differential Motion Output

Interface Circuit ›› Output Circuit ››

Below is the detailed schematic of the differential motion outputs.

Schematic:

Notes:

The differential motion outputs are designed to work with drivers with differential inputs. If you need single ended output, see the TBS option.

Applies to:

10-PIN TBB Axis Connectors Pins 7-10

CMD-4EX-SA-TBB Motion Outputs


P2A - PWM to Analog output

Interface Circuit ›› Output Circuit ››

Below is the detailed schematic of the PWM to Analog RC filter outputs.

Schematic:

PWM to Analog Filter

Notes:

The Commander PWM operate at 500hz, this RC filter converts the PWM output to an Analog output.

Applies to:

40-PIN DIO connector (I/O Expansion Connector) Pins 35 and 36

Picture showing location of general input/output


BIO - Bidirectional input/output

Interface Circuit ›› Bidirectional Circuit ››

Below is the detailed schematic of the bidirectional input/output lines.

Schematic:

Schematic of the bidirectional input/output

Notes:

The bidirectional input/output is not isolated and offers minimal protection.

Applies to:

40-PIN DIO connector (I/O Expansion Connector) Pins 3 to 28, 33 and 34

Picture showing location of general input/output

CMD-4EX-SA J7 Pins 53-58

Picture showing location of J7 58pin header


Contact NPA

Nippon Pulse America, Inc.

4 Corporate Drive, Radford, VA 24141 USA

Phone: 1-540-633-1677

E-mail: info@nipponpulse.com

Web: https://www.nipponpulse.com