Introduction

CMD-CM3-10 is a control system which integrates a servo controller and driver into a single system-level unit to simplify motion control.

  • Features
  • Connections
  • Communication
  • Accessories

This documentation provides hardware specifications for the CMD-CM3-10. See the Commander manual , Command Reference , and Software Utility Manuals for more information.

Copyright © 2026 by NIPPON PULSE AMERICA, INC. All Rights Reserved.


1.0 Features

On this page
  • Power requirements
  • Communication
  • Control
  • Motor interface
  • Feedback
  • Inputs/Outputs
  • Software

Power requirements

Logic power

Power requirements

  • Single CMD-CM3-10,
    • +12Vdc to +20Vdc 0.5 A
  • With NP-Link 1 connecting 4 CMD-CM3-10,
    • +12Vdc to +20Vdc 2.0A

Power sources (only one of these sources is needed)

  • NP-Link connection to master CMD-CM3-10 1
  • USB-C PD3.1 2
    • Single CMD-CM3-10, 7.5W (15V 0.5A)
    • With NP-Link1, 30W (15V 2A),
  • Logic power input,
    • Single CMD-CM3-10, +12Vdc to +20Vdc 0.5A
    • With NP-Link1, +12Vdc to +20Vdc 2.0A

Isolated power for all I/O

+12Vdc to +24Vdc 1.0A

Motor power

+24Vdc to +48Vdc 15Adc continuous, 30Adc peak 3

Communication

  • USB-C 2.0

HID compatible

  • RS-485 ASCII,

Selectable 9600, 19200, 38400, 57600, 115200 baud rates available

  • NP-Link 1

Available for 2 to 4 CMD-CM3-10 being used together

Back to Top

Control

  • Command control from PC through USB or serial communication (Synchronous)
  • Standalone control scripts, A-SCRIPT, a BASIC-styled programming language (Asynchronous)

Motor interface

Analog Incremental Encoder

Sin/Cos format

Differential (sin+, sin-, cos+, cos-), 1 Vp-p,

Back to Top

Feedback (each axis) continued

  • Absolute:

SSI

Clock (X, /X), Data (A, /A) signals

EnDat

  • Clock (X, /X), Data (A, /A) signals

Absolute A

    • Tamagawa Absolute A,
    • Panasonic Absolute A
    • Format, Sanyo Denki Absolute A
    • SD+, SD- (A, /A) signals

2.5 or 4 MHz, 2-wire half-duplex communication

    • Status data for encoder operating conditions and errors

BiSS (B&C)

MA+, MA- (X, /X), SL+, SL- (A, /A) signals, 4-wire, clock output from MP3, data returned from encoder

  • Buffered output of digital incremental encoder (axes X,Y,Z)
  • Encoder Frequency and Impulse Multiplier/Divider (axis X)

Back to Top

Inputs/Outputs

  • Digital Inputs (isolated)

4 opto-isolated inputs, configurable as current sink or current source in groups of 2 with 1K current limit resistor

  • Digital Outputs (isolated)

• 4 high speed opto-isolated outputs (min 10MHz, pulse width 100ns min), use for Sync or digital output

    • 1 OR output of the 4 high speed outs
    • 1 AND output of DO1(X sync) and DO2(Y sync)

• 4 GPIO (DO 1-4) opto-isolated, open drain outputs

DO3 is configurable as GPIO or E-stop indicator.

• 2 GPIO (DO 5,6) floating opto-isolated, outputs. Both legs of the opto collector are exposed, no current limiter

• 3 mechanical contact outputs. contact rated for 15A 250Vac/28Vdc

  • 20 General Purpose Input/Outputs.

•With JBD-4EX-I26 (isolated)

•Without JBD-4EX-I26 0-3.3V logic

  • 2 Analog inputs (buffered) 0-3.3V

Joystick operation using the analog input (X-axis, Y-axis)

  • Safety inputs (isolated)

•E-STOP input

•E-STOP active output (DO3)

•+/- Limits for each axis

•Home input for each axis

Back to Top

Software

Software and related documentation: https://support.nipponpulse.com/

Commander Control Utility

  • Allows for operation checks by utility software
  • Compile, write, and read standalone control scripts

NPBuilder

  • Pre-written and tested code snippets to build your application on.
  • Low code blocks can be exported to many common programing languages

NPTerminal

  • Small and fast standalone terminal program
  • Reply compare allows for testing of expected reply to actual reply
  • Runtime scripting with advanced features such as logging, go/no-go testing

Support

Support documentation: https://support.nipponpulse.com/

Commander manual

The operation manual for the Commander Family of products. It provides an overall introduction to the Commander motion controller, its theory of operation, basic communication, and programming language overview. The operation manual also includes mechanical and electrical specifications.

Command Reference

The command reference for the Commander Family of products. Provides details and examples of every command.

Commander Communication

The communication guide covers USB and use of the DLL/API, as well as RS485 communication for the Commander Family of products.

Commander Firmware Update Guide

The Firmware Update guide covers the process of updating the firmware for the Commander Family of products.

Back to Top

1NP-Link is not enabled for V2 but is planned for with V3.

2USB PD hardware is present but disabled for V2.

3Forced-air cooling may be required for operation at full output power on all axes.

Back to Top


2.0 Connections

The CMD-CM3-10 has three separate Ground plans; use the correct ground reference for the input/output you are using. Note: It is possible, (not recommended) to connect all ground plans to a single point with the power wiring.

Electrostatic Discharge (ESD) ring ground
The ESD ring protects the controller from moderate ESD events. All metalized connectors (Encoder, USB, NP-Link, Commander case and Servo Drive mounting screws) are connected to the ESD ring. This should be connected to the Earth ground through the 6 mounting holes on the Printed circuit board ( PCB).

Logic ground
The logic ground and motor power ground are shared and used as the reference for all on board signals, as well as encoder inputs, U axis outputs, and analog inputs.

Isolated (ISO-) ground
The ISO ground is used for all inputs/outputs for the CMD-CM3-10 controller unless otherwise noted.

No ground reference
Some outputs are fully floating so do not have a predetermined ground reference and are safe to connect to any ground reference. They include the Relay (MC) outputs, digital inputs, and General-purpose input/output (GPIO) 5 and 6. See the section below for more information on these outputs.


2.1 Power inputs and Status LEDs

2.0 Connections ››

Logic ground

Note: NP-Link not available on this version (V2.0)

For V2, USB PD has been disabled and the logic power must be supplied to the Logic power +12Vdc to +24Vdc input.

Do not exceed 24V on the Logic power +12Vdc to +24Vdc input at any time.

When the USB is connected the USB Connect LED will come on but the Flip and PD Active LEDs will stay off.

Power Status LED for Logic Power:

USB PWR - NP-Link power, USB PD or “+12Vdc to +24Vdc” power inputs are active.

5V - 5V regulator is active. Used for U-axis out and pull up for inputs.

3V3 - 3.3V regulator is active. Used for Commander.
Isolated power for all I/O: (Isolated (ISO-) ground)

Power Status LED for Isolated power

ISO PWR - “+12Vdc to +24Vdc” isolated power input is active.

ISO 5V - 5V regulator is active. Used for Sync/DO outputs and DO1 to DO4 outputs.

ISO 3V3 – iso 3.3V regulator is active. Used for NP-Link CAN output.
Motor Power: (Logic ground)

Power Status LED for Motor Power

DC IN “+24Vdc to +48Vdc” power input is active.

M Fuse – Fuse for motor power is good.

Motor – Power to Drive is active. If off check E-Stop is not active.

+24Vdc to +48Vdc

Mating connector: TERM BLOCK PLUG 2POS 5.08MM MFG: On Shore Technology PN: EDZ950/2


2.2 Digital Inputs

4 opto-isolated inputs (No ground reference), configurable as current sink or current source in groups of 2 with 1K current limit resistor.

Digital

COM Connect to ISO+ for SINKING input. Connect to ISO- for SOURCING input.

DI1,DI2 share a COM input. DI3,DI4 share a COM input.

DI1-4 –

If COM is set to SINKING connect ISO- to activate input.

If COM is set to SOURCING connect ISO+ to activate input.

ISO+ and ISO- are supplied for easy connection but any power connection can be used. Ensure the input signal and the COM connection share a common ground reference.


2.3 Digital Outputs

4 high speed opto-isolated outputs (Isolated (ISO-) ground), used for Sync or digital output.

Logic level signal (+5V) referenced from ISO-

X (DO1) Y (DO2), Z (DO3), and U (DO4) are 5V referenced from ISO-.

Controlled by the DO command or by the SYNC function.

https://support.nipponpulse.com/NPA_Command_Reference/DO-DigitalOutputStatus.html

https://support.nipponpulse.com/NPA_Command_Reference/SYNC-SynchronizationMode.html

OR output LOW if all SYNC/DO are low, otherwise HIGH (5V referenced from ISO-)

X&Y output of DO1(X sync) and DO2(Y sync) output inverted, LOW when both X, Y HIGH, otherwise HIGH (5V referenced from ISO-)

4 GPDO (GPDO 1-4) opto-isolated output (Isolated (ISO-) ground), used for General purpose outputs.

Open-drain outputs referenced from ISO-

GPDO1 (DO1) GPDO2 (DO2), GPDO3 (DO3), and GPDO4 (DO4) are open-drain referenced from ISO-.

Controlled by the IO command.

IO21 GPDO1

IO23 GPDO2

IO25 GPDO3

IO27 GPDO4

GPDO3 is configurable as E-stop indicator or GPIO by changing the position of the shorting jumper on JP1.

GPDO3 (DO3) can be enabled by the IO command or by the E-Stop input and ESTOP command, depending on the placement of JP1.

2 GPDO (GPDO 5,6) floating opto-isolated outputs (No ground reference)

Both legs of the optocouplers collector are exposed, no current limiter. This allows the GPDO to be configured by the user as sink or source output.

  • For Sink type connection, connect the – terminal to ISO-.
  • For Source type connection, connect the + terminal to ISO+.
  • Add a resistor in line with the load to ensure the current does not exceed max rated current. Max 150mA; typical operating current 1–10mA

GPDO5 (DO5), and GPDO6 (DO6) are floating opto-isolated outputs.

Ensure a properly sized current limit resistor, allowing 1-10mA is in line with the output.

Controlled by the IO command.

IO29 GPDO5

IO31 GPDO6

3 mechanical contact (Relay) outputs (No ground reference). Contact rated for 15A 250Vac/28Vdc

MC1, MC2, and MC3 are relay contact outputs.

Controlled by the RLY command. 0 open, 1 closed.

MC1 RLY1

MC2 RLY2

MC3 RLY3

Since this is a relay contact output there is no restriction on polarity or need for a current limit resistor. Ensure load does not exceed the contact rating of 15A 250Vac/28Vdc.

Use the RLY[port] command to change the relay outputs, with 0 for an open relay and 1 for a closed relay. Example: RLY1, reads the state of relay 1 (MC1) and RLY2=1, closes the contacts of relay 2 (MC2).


2.4 Analog Inputs

2 Analog inputs (Logic ground) (Buffered) 0 - 3.3V

Joystick operation using the analog input AI1(X-axis) and AI2(Y-axis). Use Logic GND as the ground reference for analog inputs.


2.5 Safety Inputs

Safety inputs (Isolated (ISO-) ground)


2.6 E-STOP input

This is the input for the mechanical (off PCB) E-Stop switch. When activated STO2 is activated. The E-Stop input pin must be connected to ISO+ for the controller to move the motors. Logic of E-Stop cannot be changed. E-Stop can also be triggered by the ESTOP command.

 | E-Stop, can be triggered by, removing ISO+ from E-STOP input, or sending the ESTOP command. The RED LED between the +12Vdc to +24Vdc (Logic Power) input, and the RS485 input will light when E-Stop is activated. If enabled by setting of JP1, GPDO3 will also activate when E-Stop is active. To clear an E-STOP reapply ISO+ to E-Stop input, and send the CLR command. https://support.nipponpulse.com/NPA_Command_Reference/POL-Polarity.html
•+/- Limits for each axis These are the inputs for the mechanical (off PCB) end of travel limits. By default, the limit is triggered by connecting ISO- to the corresponding limit input. The signal is routed to the Commander and the MP3 servo driver. The logic can be changed, by the POL[AXIS] (bit3) command on the Commander, and the Input/Output settings of the MP3 servo driver. | +/- Limits. By default, limits are active when ISO- is connected to the limit input. CMD POL[axis](bit3) = 1 MP3 IN 2,3,8,9,14,15 = Limit LO To activate limit when ISO- is removed from the limit input, change settings to: CMD POL[axis](bit3) = 0 MP3 IN 2,3,8,9,14,15 = Limit Hi https://support.nipponpulse.com/Commander/213111LimitSwitches.html https://support.nipponpulse.com/NPA_Command_Reference/POL-Polarity.html
Home input By default, home input is active when ISO- is connected to the home input. CMD POL[axis](bit4) = 0 MP3 IN 4, 10, 16 = Home Active LO To activate limit when ISO- is removed from the home input, change settings to: CMD POL[axis](bit4) = 1 MP3 IN 4, 10, 16 = Home Active Hi https://support.nipponpulse.com/Commander/213113Homeswitch.html https://support.nipponpulse.com/NPA_Command_Reference/POL-Polarity.html | Home input for each axis These are the inputs for the off PCB home input. By default, a home is triggered by connecting ISO- to the corresponding home input. The signal is routed to the Commander and the MP3 servo driver. The logic can be changed, by the POL[AXIS] (bit4) command on the Commander, and the Input/Output settings of the MP3 servo driver.

STO theory of operation

When E-Stop is triggered:

Timing What Happens

0ms All Axis in motion decelerate to stop.

100ms All Motion commands to motor driver is stopped and motion cannot be started on all axis.

200ms Motor Power is removed from motor drive. Logic power is left on.

440ms All motor windings connected to pins 1 and 2 are disconnected from the drive.


2.7 Encoder Inputs/Outputs

U axis Output (Logic ground)

The U-Axis output can be used to drive a 4th motor or as an encoder divider for the X axis feedback.

External driver

There is a logic level Pulse/Direction/Enable output and Encoder input for the U-Axis. These can be connected to an external driver, to drive a 4th axis from the Commander. Leave these outputs disconnected if using the encoder divider for the X-axis feedback.

U-Axis encoder input pinout

Pin 1 – A+ Pin 2 – A-

Pin 3 – B+ Pin 4 – B-

Pin 5 – Z+ Pin 6 – Z-

Pin 7 – 5V Pin 8 – 0V (gnd)

Pin 9 – 15 – N/C

Encoder divider of X-axis feedback

J400 can be used as a multiplier/devider or the X-axis encoder. The output ratio is determined by the settings of the MPD/MPM commands, and enabled by the MP/MPE commands.

X-axis Encoder Divider pinout

Pin 2 – A- Pin 6 – A+

Pin 3 – B- Pin 8 – B+

Pin 5 – gnd

Pin 9 – Axis U enable out.

Pin 1, 4, 7 – N/C

https://support.nipponpulse.com/Commander/252ManualpulsegeneratorMPGoperat.html


2.8 General Purpose Input/Output

There are 20 general purpose individually selectable input/outputs at connector J85. They can be used directly, or with the use of the JBD-4EX-I26 break out board. These are controlled/read with the IO command IO1-IO20

  • With JBD-4EX-I26 breakout board (Isolated (ISO-) ground) Recommended
    The breakout board provides easy connection and added opto-isolators to 20 additional general-purpose input/outputs.
  • Without JBD-4EX-I26 breakout board (Logic ground)
    To access the 20 GPIO you will need a custom-built cable. This along with the fact that you will be connecting directly to the Logic level (0-3.3V), requires extra caution when using the direct connect method.

Mating connector: 40Pos 1mm pitch MFG: JST PN: SHDR-40V-S-B


2.9 Encoder Input Connection

Encoder [Feedback] inputs (X, Y, Z axis)

Each axis (X, Y, and Z) has an Encoder input, and an Encoder output. The output is buffered by a 74LVC07A or equivalent Hex buffer from the input encoder digital incremental signal.

Pin outs

Encoder IN Incremental: DBHD-15 Digital Incremental Encoder Pin 1 – A+ Pin 2 – A- Pin 3 – B+ Pin 4 – B- Pin 5 – Z+ Pin 6 – Z- Pin 7 – 5V Pin 8 – 0V (gnd) Pin 9 – 15 – N/C | Absolute: DBHD-15 SSI Pin 1 – Dat Pin 2 – /Dat Pin 5 – Clk Pin 6 – /Clk Pin 7 – 5V Pin 8 – 0V (gnd) Pin 9 – sin+ Pin 10 – sin- Pin 11 – cos+ Pin 12 – cos- Pin 3 – 4 & 13 - 15 – N/C
Analog Incremental Encoder Pin 9 – sin+ Pin 10 – sin- Pin 11 – cos+ Pin 12 – cos- Pin 7 – 5V Pin 8 – 0V (gnd) Pin 1 – 6 & 13 - 15 – N/C | EnDat Pin 1 – Dat Pin 2 – /Dat Pin 5 – Clk Pin 6 – /Clk Pin 7 – 5V Pin 8 – 0V (gnd) Pin 3 – 4 & 9 - 15 – N/C
Digital Hall Effects Pin 13 – Hall V Pin 14 – Hall W Pin 15 – Hall U Pin 12 – cos- Pin 7 – 5V Pin 8 – 0V (gnd) Pin 1 – 6 & 9 - 12 – N/C | Absolute A Pin 1 – SD+ Pin 2 – SD- Pin 7 – 5V Pin 8 – 0V (gnd) Pin 3 – 6 & 9 - 15 – N/C
 | BiSS (B&C) Pin 1 – SL+ Pin 2 – SL- Pin 5 – MA+ Pin 6 – MA- Pin 7 – 5V Pin 8 – 0V (gnd) Pin 3 – 4 & 9 - 15 – N/C
Encoder Out - Incremental Pin 1 – Z- Pin 7 – Z+ Pin 2 – A- Pin 6 – A+ Pin 3 – B- Pin 8 – B+ Pin 5 – gnd Pin 4 & 9 – N/C |

Motor Out

Motor winding Pinout

Stepper

Pin 1 – A Pin 3 – /A

Pin 2 – B Pin 4 – /B

Servo

Pin 1 – V Pin 3 – W

Pin 2 – U Pin 4 – N/C

Drive status:

AMP LEDS Next to Motor phase connections

The two LEDs show the states of each axis of the MP3 by changing color, and either blinking or remaining solid.

The possible color and blink combinations are:

• Green/Solid: Drive OK and enabled. Will run in response to input commands.

• Green/Slow-Blinking: Drive OK but NOT-enabled. Will change to Green/Solid when enabled.

• Green/Fast-Blinking: Positive or Negative limit switch active. Drive will only move in direction not inhibited by limit switch.

• Red/Solid: Transient fault condition. Drive will resume operation when fault is removed.

• Red/Blinking: Latching fault. Operation will not resume until drive is Reset.