Introduction to motion control

Motion control at its basis is the accurate, repeatable positioning of motors. Precise motor control is the hidden technology that makes modern tools like 3D printers and surgical robots work. However, not all motion control systems perform equally. Some excel at holding a position with ironclad repeatability, while others adapt on the fly to handle unpredictable loads at blistering speeds. In this training module, we’ll explore the workhorses of motion control:

  • Key differences in motor types, winding chooses, driver types, control methods, and feedback mechanisms.
  • Applications where each motor excels (e.g., open-loop vs. closed-loop systems).
  • Control challenges and how dedicated motion control LSIs simplify implementation.

Behind every high-precision motion system is a fundamental choice: stepping motor or servo motor? This isn’t just an engineering decision; it’s a trade-off between simplicity and sophistication, cost, and capability, rigidity, and adaptability. We will uncover why choosing the right one can mean the difference between a system that works and one that excels.

In this introductory section, we will broadly examine motion control, point out where it appears, discuss the most common motor types, explain what is necessary to position a motor accurately, and describe how a motion control LSI works. Later sections will dive deeper into each of these topics.

Introduction: Motion control is actively used in places like these!

Topics:

    • Part 1 Everyday Products
    • Part 2 Medical/Analytical Equipment
    • Part 3 Industrial Machinery
    • Motor Types
    • What makes a motor perform with such excellent positioning accuracy?
    • Why use a Motion Control LSI?
    • Easy way to get started with a Motion Control LSI in your system

Everyday Products

Many products that you may interact with every day use stepper or servo motors.

Surveillance and monitoring cameras The orientation of surveillance and monitoring cameras needs to be controlled to capture specific areas or targets. Horizontal left-right movement is called “Pan”, and vertical inclination movement is called “Tilt”. Stepping motors accomplish the operation of these mechanisms. The strength of stepping motors is that they rotate by a fixed angle according to the number of input pulse signals. Therefore, the camera’s orientation can achieve high precision even with open-loop control and no position sensors. Additionally, servo motors are actively used in large cameras, such as in weather cameras. | Surveillance and monitoring cameras
3D Printer Small 3D printers, especially with the popular FDM (Fused Deposition Modeling) method, create objects by stacking thin layers while melting resin filament. In such applications, precise positioning according to the required accuracy of the modeling is essential. Stepping motors and servo motors meet this demand. |
Inkjet Printer Inkjet printers use stepping motors for two key functions that affect print quality: moving the print-head with precision and feeding the paper accurately. Stepping motors are more affordable since they don’t require position encoders or complex feedback loops. That reduces the number of components used in the system, thus lowering manufacturing costs. | Inkjet Printer
Air Conditioner Stepping motors rotate according to pulse signals, allowing precise control of the louver angle to adjust wind direction. It prevents wind from hitting the body, circulates air throughout the room, or allows pinpoint airflow to specific locations. Air conditioners used in living rooms and bedrooms emphasize quietness. Stepping motors face challenges with vibration and noise caused by the stepping movement; however, with the development of micro-step drive technology, smooth and quiet operation is now possible. | Air Conditioner
Automobile (Interior) Stepping motors are utilized in meters and air conditioner vents. They are designed to rotate by a fixed angle with pulse commands, allowing them to stop and hold at precise positions without sensor feedback. This makes the motors suitable for precise control of meter needles or air-conditioning louvers. | Automobile Interior
Headlight Alignment Loading heavy luggage in the car trunk or having many passengers in the rear seats can cause the rear of the vehicle to sink, misaligning the headlight axis upwards. An ‘auto-leveler’ function corrects the axis misalignment because this condition can blind oncoming vehicles. Even non-luxury cars can easily adjust the axis with a switch at hand. In such situations, stepping motors adjust the axis up and down by moving the reflector within the light unit based on commands from the control module. | Headlight Alignment

Medical/Analytical Equipment

Medical devices and analytical equipment requires high reproducibility and precision for tasks such as accurately dispensing small amounts of liquid, moving tiny samples to specific positions, or precisely moving optical lenses. Stepping motors can meet these demands at low cost.

Syringe Pump The expected function of a syringe pump is to dispense accurate amounts of liquid. Stepping motors can rotate according to the number of input pulse signals. By attaching a lead-screw or a ball-screw to the motor’s rotation axis to convert rotational motions into linear motions, the syringe piston can be accurately and stably dispensed. Also, stepping motors with built-in screw mechanisms are available. | Syringe Pump
Tube Pump The movement of a tube pump involves squeezing a flexible tube with rollers and pushing the crushed part to dispense liquid. To control the pump’s flow rate, the roller speed must be precisely controlled. Stepping motors are suitable for such applications, as they operate in sync with the pulse train speed in a simple control configuration. Tube pumps have the advantage of dispensing high-viscosity liquids or slurries (mud-like liquids) without clogging due to their structure. Stepping motors output strong torque when starting slowly at low speeds, making it easier to dispense highly viscous liquids. | Tube Pump

Industrial Machinery

Many industrial machines often position and transport heavy products or parts at high speed or perform processing which requires large force. Positioning motors are actively used in such situations. Stepping motors tend to lose torque at high speeds, so servo motors, which can output relatively large torque from medium to high speeds, are actively used in applications requiring significant output.

Semiconductor Manufacturing Equipment Wafer acceptance and transport use transporting robots (horizontal multi-joint robots) shown on the right side of the image. Servo motors and stepping motors are utilized in various processes, including direct transport mechanisms, wafer processing, and bonding and packaging of cut elements. | Semiconductor Manufacturing Equipment
CNC Machine CNC machines have multiple axes, such as X, Y, and Z axes (sometimes four or more axes), and move tools or work pieces according to the desired object shapes. Due to the nature of CNC machining, which involves cutting the object, tools must be moved continuously without stopping to avoid uneven machining results. Providing continuous commands to servo motors is required for continuous machining. | CNC Machine
Soldering Equipment The figure shows a soldering robot as an example of an automatic assembly device. Servo motors and stepping motors are used in the drive parts of such devices, such as the X, Y, and Z axes, to ensure accurate movement to the desired position. In automatic assembly devices, servo motors are used when high speed, power, and precision are required, while stepping motors are used for cost effective and precise positioning in small/desktop type devices. | Soldering Equipment
Robot Arm Precise positioning is essential for robot arms to grasp work pieces (target objects) or move tools (welding torches, grippers, etc.) to accurate positions. In robots that exert strong force, servo motors perform closed-loop control to reach the target position accurately. This control can be performed by continuously correcting the error between the target position and the current position based on the feedback from an encoder by closed-loop control. | Robot Arm

Motor types

Many motor types exist, each with its own advantages. When we look at motors for positioning applications, ‘stepping motors’ and ‘servo motors’ rise to the top of the pack. Here are several applications where stepping and servo motors are utilized.

Stepping motors at their core are positioning motors, not requiring any outside feedback to position to a highly repeatable position. Stepping motors rotate by a fixed angle (step angle) based on the number of input pulse signals. For example, a motor with a 1.8° step angle rotates precisely 18° when given 10 pulses. This direct relationship between pulses and rotation allows for simple, precise control without feedback. Their mechanical structure enables them to hold a position without oscillation or dithering.

Servo motors do not have a mechanical structure to hold a position. Servo motors fundamentally operate as thrust (force for linear) motors. They use a closed-loop control to adjust position, speed, and torque based on real-time feedback from an encoder. This gives servo motors biggest advantage in that they actively correct errors to maintain accuracy under varying loads or high speeds. Because of this, they exhibit slight dithering (small oscillations between encoder counts) when holding a static position.

While steppers and servos serve different needs, it is possible to combine their strengths by adding an encoder and servo driver to a stepper motor, creating a hybrid system that leverages the stepper’s repeatable positioning with the servo’s closed-loop precision

Use | Name | Classification of the motor | Control | Speed | Positioning resolution
Speed control, positioning | Stepping motor | 2 or 4-phase stepping motor | Constant current control, constant voltage control | 0 ~ 3000rpm | 15° to 0.9° depending on the motor.
Speed control, positioning | Closed-loop stepping motor | 2 or 4-phase stepping motor | Servo control | 0 ~ 3000rpm | 0.036 °
Speed control, high-precision positioning | Servomotor | Brushless DC motor surface magnet type | Servo control | 0 ~ 3000rpm (Instant 5000rpm) | 0.000000059° (24bit)

What makes a motor perform with such excellent positioning accuracy?

While both stepping and servo motors are excellent at positioning, they can not do it by themselves. They require a motor control system. What are the key blocks of the stepping and servo motor control systems?

Stepping Motor Control System

Due to its internal structure, a stepping motor can hold its current position when excited (windings are energized) and rotates by switching the excitation, enabling precise positioning without sensors. To rotate the motor, a stepping motor driver switches the current direction to the windings according to pulse signals, with the switching order determining direction. Even when no pulses are applied, the windings remain energized to generate holding torque, allowing the motor to maintain position with high repeatability—stopping cleanly at a defined step without oscillation or dithering.

Stepping Motor Control Configuration

Servo Motor Control System

Servo motors generally operate at higher speeds and larger torque ranges than stepping motors. They use encoder signals as feedback for high-resolution, closed-loop control. The servo driver compares the motor’s current position (from the encoder) to the command position (pulse count input from the controller), adjusting the motor’s rotation to eliminate the difference—known as deviation or accumulated pulse error. Unlike steppers, which hold position statically, servo motors continuously regulate their position, often exhibiting slight dithering (small oscillations between encoder counts) when maintaining a fixed location.

Servo Motor Control Configuration

Why use a Motion Control LSI?

In positioning control, to prevent problems such as position misalignment due to inertia, motors are gradually accelerated, driven at a constant speed, and finally decelerated to stop as shown in the upper part of Figure 1 (the horizontal axis is time, and the vertical axis is speed). When expressed as pulse trains, they become the pulse waveform shown in Figure 1. However, if you try to accurately generate pulses that change gradually over time using only the timer interrupts of a microcontroller, it will consume a large amount of the microcontroller processing resources.

Figure 1 : Motor speed transition... accurately generating pulses that gradually

change over time using only micro-controller timer interrupts is challenging.

In addition, attempting to handle output pulse counting, current position counting, deceleration start position determination, and limit-switch processing solely with a microcontroller is a significant burden. Considering these points, just using a pulse control LSI allows for efficient and precise control of positioning motors.

Figure 2 : Motion Control LSI can coordinate control of X and Y axes,

enabling easy creation of diagonal movements.

The Motion Control LSI, ‘PCL6046’, explained here also enables “linear interpolation” operation for 2 or more axes motors (Figure 2). This movement can be applied to XY tables used in manufacturing and inspection equipment, where the X and Y axes are synchronized to move diagonally in the shortest and most accurate path.

Easy way to get started with a Motion Control LSI in your system

Imagine a motion control solution so flexible that it adapts to your vision — not the other way around. A solution where prototyping and production speak the same language, where scalability isn’t a bottleneck, and where precision isn’t sacrificed for convenience. That’s the Commander Ecosystem.

The Commander Ecosystem, is a family of motion control products, (hardware, software, support, and design) built around a shared approach to motion control. The heart of which is the Commander Motion core, a secure, easy-to-use hybrid IC built around the Nippon Pulse ASIC, PCL6046, Motion Control LSI, and an ARM microcontroller.

The Commander Ecosystem hardware includes programmable motion control ICs for embedded design, standalone controllers for ready-to-deploy applications, and the new Control Max series, which integrates a servo controller and driver into a single system-level unit.

All Commander Ecosystem products share a common software platform, so code written for one transfers seamlessly to another — empowering you to prototype with agility and scale to production with confidence.

In section " Commander Ecosystem " we will dive deeper into the Commander Ecosystem and discover motion control that adapts to your vision.

We took you on a journey through the world of motion control—from the pulse-driven precision of stepping motors to the dynamic, feedback-driven power of servos. We explored how steppers dominate in open-loop applications where cost, repeatability, and simplicity matter, like in inkjet printers or medical syringe pumps. We saw how servos shine in high-speed, high-torque environments where adaptability is key, such as in CNC machines or robotic arms. And we uncovered the hybrid systems that blend the best of both worlds. But we also exposed a fundamental challenge: control complexity. Generating smooth acceleration curves, synchronizing multi-axis movements, and processing encoder feedback in real time can overwhelm even the most powerful microcontrollers. That’s where the motion control LSI steps in—not just as a helper, but as a game-changer. By offloading pulse generation, interpolation, and error correction to dedicated hardware like the PCL6046, an LSI frees your system to focus on what matters most: performance, precision, and reliability. But how do you harness this power in your own designs?

Now that you’ve seen the why behind motion control LSIs, the next section dives into the how—starting with the very foundation of stepping motors. This section will cover the details of PM and HB steppers, including windings, micro-stepping, and torque. Discover how these motors move in distinct steps and why their design ensures accurate, consistent placement. Learn how constant current control and micro-stepping transform a basic stepper motor into a precise tool. Ready to delve deeper?

Next Section

Copyright © 2025-2026 by NIPPON PULSE AMERICA, INC. All Rights Reserved.


Stepping motors

Precision isn’t just about where a motor ends up—it’s about how it gets there and how firmly it stays there. Whether it’s the silent, micron-level movements of a 3D printer building a medical implant or the relentless torque of a CNC machine carving aerospace components, stepping motors are the unsung heroes of motion control. But not all steppers are created equal. Some thrive in cost-sensitive applications where simplicity reigns, while others push the boundaries of resolution and torque to meet the demands of high-precision robotics. In this chapter, we’ll dissect the two titans of stepping motor technology—Permanent Magnet (PM) and Hybrid (HB)—revealing how their unique structures, winding methods, and drive techniques shape their performance. You’ll discover why a PM motor might be the perfect fit for your air conditioner’s louvers, while an HB motor could be the backbone of your next CNC project. And we’ll uncover the trade-offs behind every design choice, from unipolar vs. bipolar drives to constant voltage vs. constant current control. By the end, you’ll know exactly how to harness the full potential of stepping motors—and when to push beyond their limits.

Structure and Mechanism or Motion: Stepping Motors

Topics:

    • Structure of PM (Permanent Magnet) type stepping motors
    • Simple and basic drive method: Constant Voltage Drive
    • Structure of HB (Hybrid) type stepping motors
    • Positions of the stator and rotor teeth of HB type stepping motors
    • Coil winding method
    • Drive methods (Unipolar and Bipolar)
    • How to apply current to the windings of a motor
    • Differences in characteristics depending on the drive method
    • Excitation methods
    • Torque characteristics of stepping motors
    • Out-of-step and Hunting can hinder stable motor operations

The two primary types of stepping motors are Permanent Magnet (PM) often called can stack, and Hybrid (HB) stepper motors. PM stepping motors use a rotor with embedded permanent magnets and offer simple control with a power-off detent. Hybrid motors utilize a toothed rotor with an axially magnetized permanent magnet, to maximize power, resolution, and torque in a compact size. HB stepper motors are generally the preferred choice for applications requiring high precision, such as CNC machines, 3D printers, and robotics, due to their superior step resolution and torque characteristics. PM motors provide a balance of cost and performance for less demanding tasks. Let’s explore the design of typical PM and HB stepping motors, focusing on their common and unique features.

Structure of PM (Permanent Magnet) type stepping motors

PM stepping motors consist of a rotor, magnetized in the axial direction, and coils within the yoke. They incorporate magnets that enable them to rotate. We will explain the structure based on Figure 1.

PM stepping motor structure

Figure 1 : Overall view of structure

PM stepping motor rotor

Figure 2 : Rotor (Example of 24 poles and 24 magnetizations)

PM stepping motors’ rotating part (rotor) alternately magnetize with north (N) and south (S) poles vertically as seen in Figure 2. A 15° step angle motor combines a total of 24 N and S poles.

The fixed part of PM stepping motors (stators) has parts called poles around which coils are wound, and when current flows through the coil, the poles become electro-magnets. By changing the direction of the current flowing through the coil, the rotor’s magnets attract or repel each other, causing the rotor to move. A motor with a step angle of 15° has 24 poles.

PM type stepping motors rotate gradually as the rotor’s magnets and the stator’s poles attract and repel each other. One rotation is 360°. With 24 rotor magnets and 24 stator poles, 360° ÷ 24 = 15°, meaning the rotor is designed to rotate 15° per electrical signal (one step).

Photo 1 : Apperance

Photo 2 : Disassembled part

Photo 3 : Enlarged view of the coil part

Photo 3 is an enlargement of the coil part. The coil is wound around a donut-shaped bobbin, and when current flows through this coil, the claw-shaped poles inside become electro-magnets. There are two sets of these, and by changing the direction of the current flowing through each coil in a predetermined sequence, the upper and lower poles change to N or S accordingly. The change in the magnetic poles causes the rotor’s magnets to be attracted and repelled, resulting in rotation. By speeding up or slowing down the current flow sequence, the rotor rotates faster or slower.

Simple and basic drive method: Constant Voltage Drive

Constant Voltage Drive is the usual method for driving PM stepping motors, applying a fixed voltage to coils for current. This method has the advantage of a relatively simple circuit configuration, making it easy to reduce costs.

CW Rotation | A-phase (#1-Phase) | /A-phase (#3-Phase) | B-phase (#2-Phase) | /B-phase (#4-Phase) | CCW Rotation
1 | ON | OFF | ON | OFF | 4
2 | OFF | ON | ON | OFF | 3
3 | OFF | ON | OFF | ON | 2
4 | ON | OFF | OFF | ON | 1

Table 1 : Transistor ON/OFF sequence during 2-phase excitation

In a stepping motor with constant voltage drive, transistors sequentially turn the current to the coils ON/OFF, switching the magnetic poles. This causes the rotor’s permanent magnets to be attracted or repelled by the magnetic poles, resulting in precise step rotation. The 2-phase excitation method especially achieves high torque and stable rotation through constant excitation of two coils (Figure 3, Table 1).

Drive transistors and coil

How the rotor rotates

Figure 3 : Rotor rotation by Constant Voltage Drive

Structure of HB (Hybrid) type stepping motors

A Hybrid type stepping motor shown in Photos 4-6 operates by fixed magnetic field created by the permanent magnet inside the rotor and the changing magnetic field by the current flowing through the stator’s coil, with each fine tooth attracting or repelling each other to rotate in precise steps.

Photo 4 : HB Type Stepping Motor

Overall

Photo 5 : Internal structure

Photo 6 : Rotor

A rotor (rotating part) is characterized by the permanent magnet embedded in its center (Figure 4-6). This permanent magnet is arranged to penetrate the rotor, and at both ends, parts called rotor cores with convex small teeth are attached.

Figure 4

Figure 5

Figure 6

Inside the motor, a stator (fixed part) is arranged to surround the rotor, and there are poles (protrusions with teeth) around which coils are wound. These poles also have convex small teeth like the rotor.

Positions of the stator and rotor teeth of HB type stepping motors

Let’s look deeper into the about 2-phase HB stepping motors. The figure below illustrates how the poles of the stator’s and rotor’s small teeth are positioned relative to each other. To make it easier to understand, we will explain it on a flat plane instead of using a circular shape.

The stator’s poles are located at 45° intervals, totaling eight. Each pole has coils wound around it so that it becomes an electromagnet when current flows. The direction of the current flow determines whether the small teeth become either N (North) or S (South) poles. Rotor 1 and Rotor 2 each have 50 small teeth per rotation with concave and convenes alternating, and they contain permanent magnets inside.

Rotor 1 is the North pole and Rotor 2 is the South pole. The pitch of the peaks of the rotor’s small teeth is 7.2°, and the pitch of the peaks of Rotor 1’s and Rotor 2’s small teeth is 3.6°. The stator’s small teeth and the rotor’s small teeth are offset by 1.8° for each pole as shown in Figure 4 below.

Figure 7 : Teeth of Rotor 1 and Rotor 2 are offset

The winding direction of A- and B-phase coils is opposite to that of /A and /B-phases.

Coil winding method

Regardless of PM type or HB type, there are two types of coil winding methods for stepping motors: unifilar winding and bifilar winding (Figure 8). Unifilar winding is a method of winding with a single wire.

Figure 8 : Coil Winding Method

Drive methods (Unipolar and Bipolar)

Regardless of HB type or PM type, there are two types of drive methods for stepping motors: Unipolar Drive and Bipolar Drive. These drive methods differ in the way the current is applied to the coil, and then how many transistors will be required accordingly.

Unipolar drive

Unipolar drive is a method of driving stepping motors by applying current in only one direction to the coil. The bifilar winding method uses two coils on the stator, and the current flows from the common line (COM) to the target coil winding in one direction. Since the direction of the current does not need to switch, the circuit becomes simple.

Each coil winding requires one transistor to control the ON/OFF of the current. Generally, four transistors are used for a 2-phase stepping motor.

The advantages of this Unipolar drive are that the circuit configuration is rather simple, and control is relatively easy. Faster current direction changes are possible since there’s no reverse current to overcome with each switch, enabling 40% higher speeds when compared to a Bipolar drive. While the disadvantage is that only half of the coil is used, resulting in smaller torque generation (especially at low speeds). Power consumption is also inefficient.

Bipolar drive

Bipolar drive is a method of driving by alternately applying current from both directions to a unifilar-wound coil. By switching the direction of the current, the magnetic poles of the coil will be reversed.

Using switching elements (transistors) connected to both ends of the coil, the current is reversed while flowing. This allows efficient use of the entire coil.

To perform the bidirectional control of current, a circuit called the “H-bridge circuit” is required. Typically, four transistors are required for one coil, and a total of eight transistors are used for a 2-phase stepping motor.

An advantage of this Bipolar drive is that the entire coil is used, allowing for greater torque generation than a unipolar drive, at low speeds. While the disadvantages include the circuit becoming complex due to the H-bridge circuit, and the cost is higher than unipolar drive due to the large number of transistors used. Plus, the current has to switch direction, which fights against a reverse current with every switch. This reduces the top speed when compared to a unipolar drive.

How to apply current to the windings of a motor

Performance isn’t only about whether the drive is unipolar or bipolar; the current control method matters too. Let us now review the common methods and their advantages and disadvantages.

Constant Voltage Drive

The Constant Voltage Drive is a method of constantly applying a fixed voltage to the motor coils. The coils have resistance (R) and inductance (L) components, so it’s easy to assume that the current is determined by voltage ÷ resistance (I = V/R). However, the motor coils have high inductance, so the current does not immediately reach its maximum value even when voltage is applied. It has a characteristic that the current rises slowly.

Since it only requires a circuit to maintain constant voltage, the configuration is relatively simple, allowing for cost savings.

The current flow becomes too weak as the motor speeds up. Consequently, torque generation decreases sharply, making it prone to out-of-step (a phenomenon where the motor skips steps). Even at low speeds or when stopped, the rated current constantly flows through the coil, leading to a tendency for increased heat generation. Due to its inferior performance at high speeds, this driving method has not been widely used recently.

Constant Current Drive (Chopper Drive)

The constant current drive is a method that controls the current flowing through a motor coil to maintain a constant value. To address the issue of current rising difficulty due to coil inductance, the current is controlled by applying a higher voltage and temporarily cutting off the voltage (chopping) when the current is about to exceed the set value.

By counteracting the influence of coil inductance, it allows quick current flow even at high rotating speeds, maintaining stable torque across a wide range of speeds. This makes it less prone to out-ofstep. However, since the circuit is required to monitor the current and rapidly switch the voltage ON/OFF (chopping), it is more complex and costly compared to the constant voltage drive.

Features like current-down function, which reduces the current value as needed, can be utilized to easily suppress heat generation during stops.

Precise control of current values allows for smoother and more accurate positioning when combined with micro-step drive (a drive method that further divides each steps).

In recent applications where high-speed performance and stability are required, this constant current drive method has become the mainstream. Various driver ICs for stepping motors adopt the constant current drive.

Differences in characteristics depend on the drive method.

The characteristics of combinations involving the Unipolar Drive, Bipolar Drive, Constant Voltage Drive, and Constant Current Drive are as shown in Table 2.

Winding/ Drive method | Constant voltage drive | Constant current drive
Unipolar | Simple and inexpensive circuit control. Difficult to change torque characteristics. Suitable for applications where easy operation is required, not seeking characteristics | Complex circuit configuration (it can be improved by using ICs). High responsiveness. Easy to change characteristics by current. The circuit is complex, but it can effectively utilize motor characteristics. The price difference from the constant voltage drive circuit has decreased recently due to IC implementation.
Bipolar | Low speed. Difficult to change torque characteristics. Despite complex circuits, the characteristic improvement is limited, so it is not commonly used. | Complex circuit configuration (it can be improved by using ICs). Easy to change characteristics by current. Can improve the motor torque characteristics. The circuit is complex, but it can effectively utilize motor characteristics. The price difference from the constant voltage drive circuit has decreased recently due to IC implementation.

Table 2 : Differences in characteristics depending on the drive method

Here is a video about these differences.

MPEG movie player required: lib/Comparison of torque depending on the steppin.mp4

Excitation methods

1-phase excitation

In this method, only one phase (coil) constantly receives excitation in a 2-phase stepping motor. In this method, the motor operates by a basic step angle. For a basic step angle of 1.8°, it rotates once by 200 steps. Compared to 2-phase excitation, the torque generated by the motor is smaller, and the performance to suppress vibration during rotation (damping characteristics) is also inferior, so it is rarely used. See figure 9 (By Wapcaplet; Teravolt. The original uploader was Teravolt at English Wikipedia.)

Figure 9 : Example of 1-phase excitation

2-phase excitation

This method excites two phases (coils) simultaneously. It is the same excitation method as 1- phase excitation, the motor operates by its basic step angle. For a basic step angle of 1.8°, it rotates once by 200 steps. Since two coils always generate magnetic force, the torque by a motor is larger, compared to the 1-phase excitation, and the rotation is more stable. Therefore, the 2-phase excitation is the most commonly used excitation method.

Figure 10 : 2-phase excitation to drive a motor by the basic step

Figure 10 shows a specific example of 2-phase excitation. First, apply current to Aphase and B-phase, setting the stator’s small teeth the S-pole. The rotor’s N-pole small teeth are attracted to these stator’s small teeth in the S-pole. At the same time, current is applied to /A-phase and /B-phase, setting them the N-pole. The S-poles of the rotor are attracted to the N-pole. The rotor stops when the rotor and the stator are balanced.

Next, when B-phase and /A phase of the stator are set in the S-pole, and A-phase and /B-phase are in the N-pole, the rotor rotates 1.8°, which is 1/4 of the small teeth pitch of 7.2°. By changing the way of current flows through the stator sequentially, the rotor rotates by the basic step angle. Figure 10 show these 4 steps in

1-2 phase excitation (Half-Step Drive)

1-2 phase excitation is a method that alternates between 1-phase excitation and 2-phase excitation. For example, 1-phase excitation is performed in the first step, and 2-phase excitation in the next step. This alternating excitation adds intermediate stop positions to the motor, doubling the resolution. In other words, for a basic step angle of 1.8°, it rotates once in 400 steps. This enables smoother rotation and is particularly effective in reducing motor vibration.

Micro-step drive

Micro-step drive is an advanced excitation method to further divide the stopping position of a stepping motor. This is achieved by precisely adjusting the balance (dividing) of current flowing through multiple coils such as A-phase and B-phase(division).

Figure 11 : Micro-Step Drive Waveform

For example, in the case of “Micro-Step of 1/4” for a basic step angle of 1.8°, this 1.8° is divided into four, allowing it to stop at an angle of 1/4 (0.45° in this case). This allows the motor to position very smoothly and accurately. It greatly contributes to reducing vibration and noise, so it is widely used in medical devices, optical equipment, and precision robotic arms where high-precision control is required.

Torque characteristics of stepping motors

The torque characteristics of stepping motors are an essential element for evaluating their performance and selecting them for appropriate applications (Figure 12).

Figure 12 : Torque characteristics of a stepping motor

Holding torque...refer to the stability when stopped

Holding torque refers to the maximum torque that an excited stepping motor can maintain its stopping position against external forces or load fluctuations. This number indicates how stable the motor is when stopped; a higher number means less chance of shaking or losing its position.

Pull-in/Pull-out torque...key to understand the dynamic torque characteristics

Pull-in torque is the highest torque a motor can handle when starting from zero speed and running at a certain frequency without losing synchronization. It indicates the ability to directly start moving heavy loads, especially at low-speeds. On the other hand, pull-out torque is the maximum torque at which the rotor can follow the driving pulse frequency and operate synchronously without miss-stepping. This indicates how much the motor sustains during synchronous operation and is important for evaluating performance at high speeds. Generally, pull-out torque indicates higher than pull-in torque value.

Max self-starting frequency/ Max response frequency...how fast it can follow

Maximum self-starting frequency refers to the highest pulse frequency at which a stepping motor with no-load can start directly without out-of-step states. When exceeding this frequency, the motor cannot start normally. In contrast, maximum response frequency is the highest pulse frequency that a motor, once in synchronous operation, can follow without out-of-step states.

Synchronous operation range...set by torque and frequency characteristics

The synchronous operation range is where the rotor can operate synchronously without out-of-step states when the drive pulse frequency is gradually increased beyond the self-starting range or when the load torque is increased. When controlling at high speed, the motor must start and stop in the self-starting range, so gradually increase the speed from the self-starting frequency range. After operating in the synchronous operation range, it is necessary to control the speed to decrease and stop in the self starting frequency range.

When selecting a motor, it is necessary to choose a motor with specifications that can be controlled within this self-starting frequency range and synchronous operation range.

Out-of-step and Hunting can hinder stable motor operations

Out-of-step

Out-of-step is a phenomenon where the rotor of a stepping motor can no longer follow the changes in the excitation of a stator.

If the load on the shaft is too large, rapid acceleration/deceleration is applied, or the pulse frequency exceeds the motor’s capacity, the excitation switches before the rotor reaches the next step position, resulting in an error from the correct position (Figure 13). If this repeats, the motor will either stop or continue unintended rotations, making accurate positioning impossible.

Figure 13 : Out-of-step mechanism

Hunting/ Disturbance in operation

Hunting is different from the Out-of-step state; it is a phenomenon where a motor vibrates during step rotation. When the rotor of a motor aims for a target position, it may generate inherent vibrations (resonance) during this process. If the next pulse is input during this vibration, the forces to rotate the motor and to reverse the motor due to the vibration, may collide and cancel each other out. This causes the rotor to not move smoothly, resulting in temporary position error and operational instability. The following methods are effective as countermeasures for this problem:

  • Avoid using the hunting range: Choose a stable operating frequency band.
  • Adjustment of drive current: Optimize the current to suppress vibration.
  • Adoption of micro-step drive:Smoothen the rotor’s movement and reduce vibrations by finely dividing each step into smaller steps.
  • Addition of dampers: Attach a damper to the motor shaft to absorb vibration.

This section took you deep into the world of stepping motors, from the rugged simplicity of Permanent Magnet (PM) types to the high-resolution precision of Hybrid (HB) designs. We explored how their structures—rotors, stators, and winding methods—dictate their performance, and how drive techniques like unipolar, bipolar, constant voltage, and constant current control shape their torque, speed, and efficiency. You saw how excitation methods, from 1-phase to micro-stepping, can transform a basic stepper into a smooth, high-resolution powerhouse, and how torque characteristics like holding torque, pull-in, and pull-out torque define their real-world capabilities. But we also uncovered their limitations: out-of-step errors, hunting vibrations, and the trade-offs between cost, complexity, and performance. Stepping motors are the workhorses of open-loop positioning, but what happens when your application demands even greater adaptability, speed, or precision? That’s where servo motors come in—and in the next chapter, we’ll explore how they rise to the challenge.

Now that you’ve mastered the art of stepping motors, it’s time to meet their closed-loop counterparts: servo motors. Unlike steppers, which rely on open-loop precision, servos use real-time feedback to dynamically adjust position, speed, and torque—making them ideal for applications where adaptability is non-negotiable. In the next section, we’ll break down the structure of servo motors, from their high-speed rotors to their high-resolution encoders, and compare the three most common control methods: motion control, analog control, and serial-bus control. You’ll learn the basics of PWM (Pulse Width Modulation) and how it enables servo motors to deliver smooth, high-torque performance. Ready to close the loop?


Servo motors

Intro For servo motors

Structure and Mechanism or Motion: Servo Motors

Topics:

    • Structure of servo motors
    • Control method of servo motors
    • Elements for servo motor controls
    • Drive sequence of brushless DC motors
    • Basic knowledge of PWM (Pulse Width Modulation)

Servo motor systems enable high-precision positioning and speed control.

Structure of servo motors

Many modern high-performance servo motors are based on Brushless DC Motors. By removing brushes and commutators, this design prevents wear and electrical noise, ensuring a long and maintenance-free operation. The switching of electric current to the coils in motors achieves efficient and smooth rotation.

Figure 1 : Structure of servo motors

Stator / Forcer - Coil winding

The stator is a fixed part of a rotary servo motor, made of an iron core with coils wound around it. In coreless linear servo motor like the Linear Shaft Motor, the forcer is the moving part and only has the coil windings. The winding is 3-phase U, V, W which are connected in the most popular WYE (Figure 2) or a DELTA (Figure 3) configuration. By passing current through these coils, they become electromagnets and generate a moving magnetic field.

Figure 2 : WYE winding Figure 3 : DELTA winding

Rotor / Shaft - Magnet

On a rotary servo motor, the rotor spins, while on a linear motor like the Linear Shaft Motor, the shaft is usually fixed. These parts contain powerful permanent magnets. The movement of these motors is due to the push and pull between the electromagnets on the stator/forcer and the permanent magnets on the rotor/shaft.

Encoder - Detect position and speed

The greatest feature of servo motors is their precise feedback control. An encoder is essential for this purpose (Figure 1). An encoder, placed between the moving and fixed parts, and senses rotation or distance and speed, then changes this into electrical signals. The servo amplifier (driver) receives this information and corrects deviations from the target value in real-time. This allows the motor to accurately maintain the commanded position and speed even with external load variations. Because of this closed-loop control, many applications requiring high precision, such as industrial robots and machine tools, use servo motors.

Control method of servo motors

Control method

Features

Pulse Control

Pulse amount controls position, and pulse speed controls speed. It is the simplest and easiest to understand.

Analog Control

Position control is managed by the higher-level controller, and speed control is managed by the command voltage (analog).

The command voltage is susceptible to disturbances, which tends to make the control unstable.

Serial-bus control

Position and speed controls through serial communication called the fieldbus for the FA industry

  • Less-wiring
  • Complex simultaneous coordinated control of multiple axes
  • Vibration occurs or interpolation paths collapse if data transmission and reception between the higher-level controller and the servo driver are interrupted
  • High-end controls are required for both higher-level controllers and servo drivers

Requirements for a higher-level controller

To maintain high-speed communication, it is necessary to perform complex calculations such as position and speed within a few hundred microseconds in the fastest cases and transmit that data.

Requirements for a servo motor

It is necessary to receive, analyze, control, and transmit data from the higher-level controller within the communication cycle.

Pulse control

The method to control the motor positions by pulse amounts as well as speeds by the frequency of pulse to the servo driver.

Figure 4 : Pulse control block

Analog control

In analog control, the accurate positioning of a motor itself is basically the role of a Positioning controller [Figure 5]. The servo amplifier only provides speed based on the command voltage. The information where the motor is positioned or whether the motor has reached the target position is determined by the positioning controller with reading the encoder feedback and calculations.

Figure 5 : Analog control block

Serial-bus control

The serial control method of servo motors uses field bus communication, which is popular in the factory automation industry, to control position and speed [Figure 6]. This enables reduced wiring and allows for complex multi-axis coordinated control.

Figure 6 : Serial-bus control block

Elements of servo motor control

The drive circuit of servo motors is the essential element for achieving high-efficiency and precise control (Figure 7). The core of this circuit is to supply current to the motor’s U / V / W phases in the correct sequence.

Encoder

An encoder is essential for accurately acquiring the rotor position of a motor. An encoder tracks the rotor’s angle as it spins and sends this data to the servo amplifier’s control system.

Current control circuit

The rotor position information from an encoder and the current command from the higher-level controller (equivalent to the target torque) are input to a current control circuit. The current control circuit precisely monitors and adjusts the current flowing through each UVW phase to match the actual motor current with the current command. This constitutes the innermost current loop that determines the responsiveness and accuracy of control.

Power transistor

The output from a current control circuit is sent as FET gate control signals to the power transistor (FET) within the inverter circuit. By turning each FET’s ON/OFF, the power from a source is supplied to a motor’s UVW phase coils at the appropriate timing and amount. For example, by applying current to a specific UVW phase at a specific rotor position, torque is efficiently generated, allowing the motor to rotate smoothly

.

Figure 7 : Components in a Servo Motor system

Brushless DC motor

Most of the servo motors widely used in the industrial field adopt Brushless DC motors, which are known as “Permanent Magnet Synchronous Motor (PMSM)” as the motor component.

Drive sequence of brushless DC motors

For driving a brushless DC motor, it is popular to use the three phases: U-phase, V-phase and W-phase. This is because a brushless DC motor operates internally as a ‘3-phase AC motor’. These U, V, and W phases are arranged with the electrical angle difference of 120° between them (the mechanical angle difference varies depending on the number of poles in the motor). (Figure 8).

Figure 8 : Example of a motor to be controlled

(3-phase 2-pole)

In this section, an example of FET gate control for a 3-phase, 2-pole and 3-slot motor is shown (Figure 9).

Figure 9 : Relationship between the rotor position and MOSFET gate control voltage

As the current is stepped through the phases of the stator coils, the magnetic field of the rotor synchronizes with the magnetic flux of the stator, causing rotation as seen in Figure 10.

Figure 10 : Current flow vs flux vector

Basic knowledge of PWM ( Pulse Width Modulation)

In this section, we will explain the PWM technology, which finds frequent use in the gate control of MOSFETs for brushless DC motors.

PWM (Pulse Width Modulation) is a technology that creates an analog average voltage from digital signals. In pulse signals with a constant cycle, the average voltage of pulse waveform is adjusted by changing the ON-Time (Pulse Width). For example, if the ON-Time is half of the cycle, the average voltage will be half of the supply voltage; if the ON-Time is longer, the average voltage will be higher, and if shorter, it will be lower (Figure 11). This ratio of ON-Time is called the “Duty Cycle”. Due to rapid ON/OFF switching, the inductance of a coil smooths the current in an inductive load like a motor, enabling smooth operations.

To create a sine wave, the ON-Time is lengthened (wider pulse width) at the peaks (high voltage sections) of the waveform and shortened (narrower pulse width) at the valleys (low voltage sections) (Figure 12).

Figure 12 : AC voltage can also be created by PWM.

Changing the ON-Time of the FET changes the average voltage.

The created rectangular wave sequence contains a lot of high-frequency components (switching frequencies). Applying this wave sequence directly to a motor can cause significant noise and vibration. Therefore, an LC filter (coil and capacitor) is generally used to remove high-frequency components and extract a smooth AC waveform (close to a sine wave).

This makes sinusoidal control of the current passed through U, V and W phases is possible as shown in figure 13.

Figure 13 : Sinusoidal control with smooth flex vector

I am confused by Figure 14, the document reads that the LSI can generate this wave form, but I do not know how.

Figure 14 : How to generate PWM signals (works inside the LSI)

The time width changes by varying the comparison voltage against the triangular wave.


Basics of motor control

Intro for Basic of Motor control

Topics:

    • Positioning motors operate at a specified angle in response to control commands
    • Basic motion control operation patterns
    • Examples of motion control operation patterns
    • motion control; on-site ingenuity
    • Output pulse signal requirements for drivers
    • Control pulse specifications for drivers
    • Servo interface
    • Encoder signal counting method
    • Incremental encoder
    • Signals required for the Origin Return of motors
    • Example of Origin Return operation
    • Origin Return using the phase excitation origin of stepping motor drivers
    • Software end-limit
    • Manual Pulse Generator
    • Incremental position and Absolute position

Positioning motors operate at a specified angle in response to control commands

Positioning motors have a function to stop precisely at a specified position (angle or linear distance) in response to the given control commands. They are widely used in situations where not only moving loads but also controling the position of the load precisely is required.

Angle positioning

The smallest angle that a motor can move at one time is called “Step angle”. This angle is determined by the design of a motor itself (such as machining accuracy) and the resolution of a device that detects a motor’s rotational position (such as a rotary encoder). The smaller the step angle is, the more precise the positioning can be. Figure 1 shows the moving angle when pulses are sent to a motor of 1.8° step angle.

Figure 1 : Positioning by step angle

Speed control

The motor’s rotation speed (movement speed) is controlled by adjusting the speed at which these step angles are continuously moved using the control commands (Figure 2).

Figure 2 : Speed control ... The frequency of pulses given determines the rotation speed.

Basic motion control operation patterns

Linear acceleration/deceleration operation

When controlling a motor with pulse output, linear acceleration/deceleration is a pattern in which the speed (pulse frequency) increases linearly from the initial speed until it reaches a constant speed. Figure 3 shows the drive pattern.

Figure 3 : The trapezoid area is determined by time × speed, and it shows the feeding (movement) amount.

In the case of stepping motors, FL (Frequency Low) speed sets the self-starting area, and FH (Frequency High) speed sets the pulse frequency for self-starting area or synchronous slewing area.

▶Acceleration phase

Initially, the pulse frequency begins to increase slowly, then increases at a constant rate. This allows a motor to accelerate smoothly. Figure 3 shows the section where the speed increases linearly.

▶Constant speed phase

Once reached the target speed (frequency) , the operation speed will be maintained. Figure 3 shows this phase in the horizontal part.

▶Deceleration phase

As the target position is approached, the pulse frequency is linearly decreased at the same or a different rate as during acceleration. This allows the motor to decelerate smoothly and stop at the target position. In Figure 3, this is the part where the speed decreases linearly.

FL speed

In the case of stepping motors, current is constantly flowing through the stator circuit. It creates an attraction between the rotor and stator, which generates the largest torque at start-up. Therefore, at startup, a certain speed (FL; Frequency Low) is given, and it operates at that speed.

Servo motors operate with a delay in response to commands, so they follow and operate more slowly compared to stepping motors.

Deceleration start point (SDP: Slow Down Point)

The deceleration start point is calculated to stop pulse output when FL speed is reached.

Differences in the motor operations

There are the following differences in the operations of stepping motors and servo motors in response to the position command pulses.

Servo motors operate systematically according to the deviation amount within the driver, resulting in a delay in response to commands. In contrast, stepping motors do not have a delay in response to commands. If a delay occurs, it means the motor is in out-of-step state (Figure 4).

Figure 4 : Stepping motor vs Servo motor commanded position and speed vs actual

(a) Stepping motor ….Operation matching the position command

(b) Servo motor ….Operation with delay in response to commands

Example of motion control operation patterns

Preset operation (Positioning operation)

Operates at a predetermined feeding amount or rotation amount and stops.

Figure 5 : Preset operation

Deceleration stop operation

When a deceleration stop command or deceleration signal is input during operation, deceleration begins at that point and stops when the FL speed is reached.

Figure 6 : Deceleration stop operation

Immediate stop operation

When an immediate stop command or an immediate stop signal is input during operation, the operation stops immediately regardless of the LSI’s operating state.

Figure 7 : Immediate stop operation

Origin return operation (Figure 8)

Origin return methods can be selected based on the conditions such as placements of origin (ORG), slowdown (SD) and end-limit (EL) signals, and the combination with the encoder Z-index signal.

▶Examples of origin return operation

  • Slow-down (SD) OFF → ON to start deceleration ①, Origin (ORG) OFF → ON to stop ③
  • Slow-down (SD) OFF → ON to start deceleration ①, Origin (ORG) OFF → ON to start counting encoder Z-index ②, Stop at Z-phase count-up ③
  • Origin (ORG) OFF → ON to start deceleration ①, Decelerate to FL speed and stop ③
  • Origin (ORG) OFF → ON to start deceleration and counting encoder Z-index ②, Stop at Z-index count-up ③

Figure 8 : Origin return operations

Examples of acceleration/deceleration patterns (Figure 9)

There are various patterns of acceleration/deceleration. In linear acceleration/deceleration, there are patterns where the acceleration and deceleration duration times vary. In S-curve acceleration/ deceleration, there are complete S-curve acceleration/deceleration without linear sections and acceleration/deceleration including linear sections. There are also patterns that combine S-curve acceleration and linear deceleration.

Figure 9 : Examples of acceleration/deceleration patterns

Motion control; on-site ingenuity

In servo motors, the gain adjustment can shorten the settling time, but it often requires a significant amount of time for adjustment. In that point, it is more effective to reduce vibration by smoothing the command from the control side, like in S-curve deceleration (Figure 10).

Figure 10 : Shorten settling time of load with S-curve deceleration

By incorporating a linear section into S-curve acceleration/deceleration, the acceleration rate can be kept low, minimizing load fluctuations (Figure 11).

Figure 11 : Comparison of S-curve acceleration/deceleration and S-curve acceleration/deceleration with linear section (Jerk control)

Triangle drives can occur when FH (Frequency High) speed is too high relative to the feeding amount, or when the feeding amount is too small relative to FH speed. This drive causes a sudden rotation change toward deceleration during acceleration, delivering a significant impact to the load. To avoid this, triangle drive avoidance function is used. (Figure 12).

Figure 12 : Triangle drive avoidance

Output pulse signal requirements for drivers

The output pulse signals to the motor driver are very important for precise motor control.

Pulse output accuracy and speed ripple

To move a motor smoothly, it is required to output the pulse resolution from the motion control devices finely, continuously, and smoothly (Figure 13). If the pulse output is “coarse,” specifically if the pulse intervals are uneven or the pulse width variations are large (Figure 14), small fluctuations occur in the motor speed, creating “Speed Ripples.” When speed ripples occurs, it can cause the motor operation to be jerky, and may lead to vibration or noise.

Figure 13 : Output pulses are continuous and smooth

Figure 14 : Rough pulse outputs can cause speed ripple

Duty cycle and pulse width requirements

The duty cycle of pulse signals (the ratio of time ON) should also be considered. Generally, for stable signal transmission, it is recommended to output with the duty cycle close to 50% (Figure 15).

Figure 15 : Duty Ratio

Furthermore, the width of pulse signals (the pulse width) is also important. If the pulse duty width is extremely short, the high-speed photocoupler inside a servo driver or a stepping motor driver may not be able to accurately receive signals (Figure 16). Photocouplers are components that use light to insulate and transmit signals, but very short pulses may not sufficiently follow the ON/OFF of light. As a result, the signals may not be recognized.

Figure 16 : If the pulse signal widths is too short, they may not be received properly by the driver

Control pulse specifications for drivers

There are three types of control pulse specifications for a driver as follows.

Common pulse mode (Pulse and Direction)

Pulse signals are output from the OUTn pin, and direction signals are output from the DIRn pin. (Figure 17).

Figure 17 : OUTn and DIRn signals in the Common pulse mode (Pulse and Direction)

2-pulse mode (CW/CCW)

Plus direction pulse signals are output from the OUTn pin, and Minus direction pulse signals are output from the DIRn pin (Figure 18).

Figure 18 : OUTn and DIRn signals in the 2-pulse mode (CW/CCW)

▶Note 1... Mode confirmation

If pulses are output in the 2-pulse mode to a driver which is set in the Common pulse mode, the motor rotates only in one direction.

▶Note 2...Logic

If negative logic pulses are input to a driver set in the positive logic setting, a motor rotates in the reverse direction. Additionally, the motor will unintentionally move for one pulse when the power is turned ON.

90° phase difference mode

▶Direction

When the output of OUTn pin is 90° ahead in electrical angle compared to DIRn pin output, it indicates CW (clockwise) rotation [Figure 19(a)].

On the other hand, when the output of OUTn pin is 90° behind in electrical angle compared to DIRn pin output, it indicates CCW (counter-clockwise) rotation [Figure 19(b)].

▶Number of pulses

In the 4 times multiplication, the rise and the fall of OUTn pin output and the rise and the fall of DIRn pin output are individually counted as pulse outputs.

Figure 19 : OUTn and DIRn signals in the 90° pulse mode

Servo interface

When controlling a servomotor, the following signals are required in the servo driver (Figure 20). Here, we explain from the perspective of the motion control device shown on the left side of Figure 20.

Figure 20 : Connection between motor position control LSI and servo driver

(1) Position command pulse output

“The number of pulses = position, and the pulse frequency = speed” are commanded by the pulse output to the servo driver.

(2) Deviation counter clear output

Inside the driver, the deviation counter counts the deviation between the position command pulse and the feedback pulse. When a position command pulse is input to the servo driver, the input pulses accumulate in the deviation counter, and as the motor rotates, the feedback signal subtracts the accumulated pulses in the counter. The servo motor rotates according to the accumulated pulse amount in the deviation counter and stops when the accumulated pulse amount becomes 0 (Figure 21).

Figure 21 : Deviation counter accumulates deviation (pulse)

During origin return operation, the deviation counter is cleared to prevent passing the origin position due to accumulated pulses when reaching and stopping at the origin sensor position. Additionally, if an emergency stop is required for the servo motor, clearing the deviation counter will cause an immediate stop.

(3) In-position input

In-position is the positioning complete signal from a servo motor driver. A servo motor operates based on the accumulated pulse amount of the position command pulse and feedback pulse, so in response to the position command, the servo motor always operates with a delay (Figure 22).

Figure 22 : In-position signal is output when the servo driver’s deviation counter is within the specified pulse range

In-Position signal is output when the deviation counter of the servo driver enters the specified range of pulses. The motion control device determines that the motor has completed its movement based on this signal.

(4) Alarm input

An alarm signal is output when any alarm issue occurs. The motion control device stops the position command pulse output when this signal is input during operation.

(5) Encoder signal input

This signal tells the actual position and speed at which the motor operated in response to the position command pulse.

Encoder counting method

Encoders usually output 2-phase signals (A-phase and B-phase) with 90° phase difference. To accurately detect position and rotation amount using these signals, the counts are extracted using the multiplication processes shown in Figure 23.

Figure 23 : Extracts the counts through the multiplication processes

Incremental Encoder

Fixed slits are arranged to create a 90° phase difference with rotating slits (Figure 24).

Figure 24 : Incremental encoder

Overview of operation

An incremental encoder is a sensor that detects changes in rotations or linear movements. Inside the encoder, a disk or a scale which has evenly spaced slits (grooves or holes) is placed and is read by the light emitting element and the light-receiving element.

When a motor shaft rotates or moves, the light is blocked or passes through these slits, generating pulse signals. Usually, two pulse signals: A-phase and B-phase, are output, and they have a 90° phase difference between them. By detecting the order of this phase difference, the rotation or movement direction can be determined. Additionally, in many cases, there is a Z-phase origin signal that is output once per rotation (or a certain distance).

Measures incremental movement or rotation amount

An incremental encoder measures incremental movement or rotation amount, not the absolute position at that moment, by counting pulses from a reference point. Therefore, when the power goes off or the system is started, the Origin-return operation (movement to the reference position and pulse count reset) is required. However, due to its simple structure, low cost, and ability to handle high-speed rotation, it is widely used for motor speed controls, rotation direction detection, and simple positioning controls.

Absolute encoder to detect the absolute position

In addition to incremental encoders, absolute encoders (absolute position encoders) are available. They can always detect the absolute position of a rotating axis. Since it retains position information even when the power is OFF, the origin-return is not required upon restart. A disk with multiple tracks is engraved with unique code patterns (e.g., gray code, binary code, etc.), and the combination of signals from each slit outputs the absolute position at that moment as digital data.

Signals required for the Origin Return of motors

Many manufacturing devices include motors and encoders for position controls. Especially, when using incremental encoders, the encoder can only detect the incremental movement amount of “how much it moved”, not the absolute position of “where it is positioned now.”

The purpose of the Origin Return is to match the mechanical position and motor position control. The following switches (or sensors) are located around the single-axis table system. (Figure 25).

Figure 25 : Signals required for origin return

Plus direction end-limit, Minus direction end-limit

These switches stop the operation to prevent damage to the signal-axis table system.

Plus direction slow-down, Minus direction slow-down

These switches will slow down a motor so as to increases the positioning sensitivity to detect the origin position.

Origin position

A switch or a sensor indicates the reference position of a mechanical system. Upon detecting the signal, the system recognizes the current mechanical position and uses it as the reference point for subsequent movement amounts. Usually, it is detected in the final stage of origin return operation, and is used for resetting the position counter or setting a new reference point.

Index Z-channel

This signal is output once per motor rotation. This signal is used to improve the origin position accuracy.

Deviation counter clear

This signal resets the servo driver’s deviation counter, preventing positioning errors.

These switches and signals are used to perform the origin return operation. There are several patterns for this operation depending on the structure of a single-axis table. Also, position repeatability is required, so this operation is controlled by hardware.

Example of Origin Return operation

General motion control devices have several types of origin return operation patterns prepared in advance based on the signals required for origin return. Here, we will take an example of origin return operation prepared by the motion control LSI and explain its operation pattern with the schematic diagram (Figure 26 to right).

In this diagram, the black circle indicates the movement starting point, and the arrow indicates the operation stop point.

  • Operation 1: From the left-side of the origin, slow-down OFF, origin OFF position

When the slow-down signal (SD) turns ON, a motor decelerates from the current speed to FL speed (starting speed or low speed). Then, after detecting the rising edge of the origin signal (the moment it turns ON), the output of position command pulses to the motor will stop at the second rising edge of Z-index signal, which detects one rotation of the encoder. At the same time, it clears (sets to 0) the internal position command counter in the control system and outputs a deviation counter clear signal to the servo driver. The count number of the Z index signal can be changed by the environment settings.

  • Operation 2...From left-side of origin, slow-down ON and origin OFF

Since the slow-down signal (SD) is ON, it starts moving at FL speed without acceleration. The subsequent operation is the same as operation 1.

  • Operation 3...From the position where slow-down ON and origin ON

The operation starts with both the slow-down signal (SD) and the origin signal (ORG) are ON. Since the slowdown signal is ON, the motor moves at FL speed. Although the origin-signal (ORG) is ON, the rising edge of the origin signal is not detected, so the motor continues to move in the minus direction.

After that, when the motor moves out of the area where the slow-down signal (SD) is ON, the speed will change to FH speed (high speed). Finally, when the minus direction end-limit signal (-EL) is detected, the motor decelerates and stops at FL speed. At this time, since it stopped due to the end-limit signal input, it is judged as an abnormal stop, and the interrupt bit turns ON.

  • Operation 4...From right-side of origin, slow-down OFF and origin OFF

When the operation starts, a motor initially accelerates to FH speed. It continues to move in the minus direction, and it decelerates and stops at FL speed when the minus direction end-limit signal (-EL) is detected. At this time, since it stopped due to the end-limit signal, it is judged as an abnormal stop, and the interrupt bit turns ON.

Origin Return using the phase excitation origin of stepping motor drivers

The phase excitation origin output (initial excitation state indicating signal) is useful to ensure more reliable homing; origin return operation, of stepping motors. Stepping motors are driven by switching the direction of current flowing to each phase, and a signal is output each time when this current flow sequence (order) completes one cycle, which is called “Phase excitation origin signal (EORG) “(Figure 27).

Figure 27 : Phase excitation origin output signal - EORG

When the power is supplied to a driver, the sequence starts and an EORG signal is output from the driver. Each time a command pulse is input from the micro controller or motion control LSI to the driver, the sequence rotates one by one, and this sequence completes in four pulses, and this EORG signal is output at the end.

EORG signals can be used in the same way as Z-index signal of a servo motor. For example, consider using the slit of a disk attached to the back of a motor as the origin signal. In addition to the signal from this physical slit, using an EORG signal like the Z index allows for more accurate and reliable detection of stepping motor’s origin position. This enables more reliable origin return operation (Figure 28).

Figure 28 : Using the servo motor’s encoder signal in combination enables more reliable origin return operations

Software end-limit

You should set the software end-limits (soft limits) inside the hardware end-limits (hard limits), which are placed at the mechanical stage ends (Figure 29). The positions of the soft end-limits are managed by the main control to prevent the moves exceeding the values to move toward the hard end-limits.

Figure 29 : Place the software end-limits inside the mechanical end-limits

Manual Pulse Generator

Instead of writing programs for positioning control each time, a manual pulser device is a convenient tool to perform small manual movements or position alignment (Photo 1 and Figure 30).

A manual pulser incorporates an encoder within a rotary dial with graduations, and the operators of the pulser device rotates it while viewing the workpiece on the table for fine positioning. In the case of a stepping motor, it may go out-of-step if rotating quickly, so it is also important to suppress the speed.

The manual pulser is also referred to as a “Manual Pulse Generator”, abbreviated as MPG.

Figure 30 : Manual pulser allows fine movement by spinning a MPG wheel

Incremental position and Absolute position

Specifying an incremental position is to indicate how much you move an object from the current position of the motor as the reference point.

For example, suppose a motor is currently at a position of 1,000 pulses (or 1,000 steps). The command “Move +500 pulses in incremental position” causes the motor to advance 500 pulses, reaching a total of 1,500 pulses. In this case, no matter where the initial position is, the motor always moves the specified amount from the current position.

This drive method moves only a specific distance or angle. For example, it is used in conveyor systems that eject parts at regular intervals or in rotary stages that rotates only a specific angle.

Specifying an absolute position is to directly specify a specific target position within the entire operating range of a motor.

For example, suppose a specific target position is 3,000 pulses counted from the motor’s origin (reference 0 pulse position). Regardless of where the motor is currently located, if you command “Move to 3,000 pulses in absolute position,” the motor will always move to the position of 3,000 pulses.

To perform absolute position control, it is necessary to accurately determine the current absolute position of the motor. Therefore, when the system is powered ON or reset, it is always necessary to perform the origin return and reset the current position of the motor to 0 (or a specific reference value). When using an absolute encoder, the absolute position can always be determined, and the origin return may not be required.


Controls of Motion Control LSI

Intro for Controls of Motion Control LSI

Topics:

    • Connection between Pulse Control LSIs and CPUs (1): Parallel Bus
    • Example 1...Motorola 68000 type CPU: 16-bit data bus
    • Example 2...Intel 8086 type CPU: 16-bit data bus
    • Examples of data writing/reading on Parallel Bus
    • Connection between Pulse Control LSIs and CPUs (2): Serial Bus
    • Examples of data writing/reading on Serial Bus
    • Operation procedures of Pulse Control LSIs
    • Example of PCL controls...Creating Linear Acceleration/Deceleration operations
    • Pre-registers and Registers

The motion control LSIs from Nippon Pulse Motor includes the PCD4600 series: ideal LSIs for stepping motor control, the PCD2100 series: a compact size LSI capable of controlling both stepping and servo motors, the PCL6100 series: the cost-effective LSIs which can support servo motors, and the PCL6000 series: high-end LSIs providing excellent functionality. In this section, we will focus on the PCL6100 series LSIs and explain their control methods.

The PCL6100 series includes three models: Single-axis control (PCL6115), 2-axis control (PCL6125), and 4-axis control (PCL6145).

Connection between Pulse Control LSIs and CPUs (1): Parallel Bus

Key features include: the maximum output frequency of 15Mpps, 32-bit up-down counters, and the linear interpolation functionality. The CPU interface supports 8 and 16-bit parallel buses and 4-wire serial buses (SPI: serial peripheral interface).

Pulse Control LSIs (hereafter referred to as PCL) are connected to the host CPU via a parallel or serial bus, receiving commands from the CPU to control the motor movements.

Set the mode to match the CPU

In PCL, the mode can be set to allow parallel bus connection according to the control method of the main CPU.

● Motorola 68000 type control method, 16-bit data bus

● Renesas Electronics H8 type control method, 16-bit data

● Intel 8086 type control method, 16-bit data bus

● Zilog Z80 type control method, 8-bit data bus

Address information

Microcontrollers come in various types such as 8/16/32-bit, which indicates the number of bits in the data bus.

The number of bits in the address bus varies by microcontroller, but address information is allocated in units of 1 byte (8 bits).

When storing a number in memory, an area of 1 byte/2 bytes (= word)/4 bytes (= double word) is required depending on the size of the number, and there are two data storage methods: big endian and little endian.

For example, the address allocation for storing data like 12345678h (hexadecimal) is shown in Table 1. There are differences depending on the CPU.

Big-endian | : Motorola 68000 type, Renesas Electronics H8 type
Little-endian | : Intel 8086 type
Address | Big-endian | Little-endian
n | 12h | 78h
n + 1 | 34h | 56h
n + 2 | 56h | 34h
n + 3 | 78h | 12h

Table 1 : Address allocation for storing data 1234 5678h (hexadecimal)

Example 1...Motorola 68000 type CPU: 16-bit data bus

The procedure is more complex than the Intel method in the next section, but it is more reliable.

Control signals include R/#W signal, #LDS (Data Strobe) signal, and #DTACK (Data Acknowledge) signal (Figure 1). The R/#W signal is in read mode at H-level and write mode at L-level.

Example 2...Intel 8086 type CPU: 16-bit data bus

The Intel 8086 type control method includes control signals #RD (Read) and #WR (Write) (Figure 4). Reading occurs when #RD = L-level (CPU ← Memory) (Figure 5), and writing occurs when #WR changes from L-level to H-level (CPU → Memory) (Figure 6).

Examples of data writing/reading on Parallel Bus

The address map of PCL6145 is shown (Table 2). Note that the single-axis LSI, PCL6115 has an address map only for X-axis, and the dual-axis LSI, PCL6125 has an address map only for X-axis and Y-axis.

Connection between Pulse Control LSIs and CPUs (2): Serial Bus

The 4-wire synchronous serial bus, SPI (serial peripheral interface) is adopted.

The PCL61x5 series can control up to four sub-node LSIs with a single select signal (SS) from the Main (assuming the CPU here).

The sub-node LSI is identified by the setting status of SN0 and SN1 pins and the "device selection" data written to MOSI (Figure 8).

Examples of data writing/reading on Serial Bus

The example below shows the pulse control LSI PCL61x5 via serial bus.

Operation procedures of Pulse Control LSIs

When operating the Pulse Control LSI (PCL), follow the steps in Figure 10.

Example of PCL controls...Creating Linear Acceleration/Deceleration operations

The following explains a setting example for linear acceleration/deceleration operation shown in Figure 11. Table 12 shows the settings of each register.

Pre-registers and Registers

PCL has models with Pre-registers and Registers. WE will explain the functions using PCL61x5 as an example (Table 20).


Commander Ecosystem

Intro for Commander Ecosystem

Topics:

    • Comm

The big picture: Commander as an ecosystem

Let’s start with the simplest possible definition.

Commander is a family of motion control products built around a shared approach to motion control. The Commander ecosystem includes three broad categories:

  1. programmable motion control ICs for embedded design,
  2. standalone controllers for ready-to-deploy applications,
  3. and the Control Max series, which integrates a servo controller and driver into a single system-level unit.

That family structure matters because customers do not all start from the same point.

Some customers are OEMs building their own electronics and they want a motion control core they can embed. For them, the CMD-4CR is the conversation. Nippon Pulse describes it as an advanced, self-contained, programmable four-axis hybrid motion controller, designed to offer the convenience of a standard controller with the technology of a more custom engineered solution.

Other customers want something easier to install and integrate. They may not want to design a board around a controller core. For them, the CMD-4EX-SA is a stronger starting point. The support site describes it as a standalone, easy-to-install version of the Commander controller, with USB or RS-485 communication and the ability to run downloaded standalone programs independently of a host.

And then there is the Control Max direction. The landing page says the Control Max series integrates a servo controller and driver into a single system-level unit, and names the CMD-CM3-10 as part of that series. From a sales standpoint, even with limited public detail on the support site, the message is clear: this is about simplifying the system by combining functions that would otherwise be separate

So when we say “Commander,” do not sell it as one isolated part number. Sell it as a path:

• embedded core when the customer wants design flexibility,

• development kit when the customer wants to evaluate quickly,

• standalone controller when the customer wants fast deployment,

• and integrated system-level offering when the customer wants reduced complexity.

That is the ecosystem story.


"For Beginners" First, lets try moving a motor with Commander

Intro for "For Beginners" First, lets try moving a motor with Commander

Topics:

    • Comm